# CVE-2019-15698: Information disclosure in n/a

> Authenticated users with VariableView permissions can view sensitive values in Octopus Deploy, requiring an upgrade to remediate.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8xgg-pj9m-c8xj

## What is CVE-2019-15698?

CVE-2019-15698 is a medium-severity vulnerability in Octopus Octopus Server, published on 27 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Octopus Deploy 2019.7.3 through 2019.7.9, in certain circumstances, an authenticated user with VariableView permissions could view sensitive values. This is fixed in 2019.7.10.

## Which versions are affected by CVE-2019-15698?

It affects 1 product.


Products: Octopus Octopus Server.

## How do I fix CVE-2019-15698?

No fix has been published for CVE-2019-15698 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-15698 being exploited?

There is no known exploitation of CVE-2019-15698 in the wild and no public exploit code.

## Other vulnerabilities in Octopus Octopus Server

- [CVE-2022-2572](https://insights.sbomify.com/CVE-2022-2572/): Auth bypass in Octopus Server (critical 9.8)
- [CVE-2022-2778](https://insights.sbomify.com/CVE-2022-2778/): Security feature bypass in Octopus Server (critical 9.8)
- [CVE-2018-11320](https://insights.sbomify.com/CVE-2018-11320/): Information disclosure in n/a (critical 9.8)
- [CVE-2022-2782](https://insights.sbomify.com/CVE-2022-2782/): Auth bypass in Octopus Server (critical 9.1)
- [CVE-2024-2975](https://insights.sbomify.com/CVE-2024-2975/): Race condition in Octopus Server (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15698 and fix it if it is affected.

What it is: CVE-2019-15698 is a medium-severity vulnerability in Octopus Octopus Server, published on 27 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15698 in the wild and no public exploit code.

Affected product: Octopus Octopus Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15698/ (Markdown: https://insights.sbomify.com/CVE-2019-15698/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15698
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15698
- OSV: https://osv.dev/vulnerability/CVE-2019-15698

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15698/
Summaries are generated and may contain mistakes; the official description above is the record.
