CVE-2019-15715 MantisBT Remote Code Execution

High 7.2 Published Updated

An authenticated attacker can inject commands to execute arbitrary code on the server hosting the MantisBT bug tracker.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-15715?

CVE-2019-15715 is a high-severity command injection vulnerability in Mantisbt Mantisbt, published on 9 Oct 2019. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution.

Weakness: CWE-78

Which versions are affected by CVE-2019-15715?

4 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.

PackageAffectedFixed in
mantisbt/mantisbt PackagistAll versions1.3.20
mantisbt/mantisbt PackagistAll versions1.3.20
mantisbt/mantisbt PackagistFrom 2.0.02.22.1
mantisbt/mantisbt PackagistFrom 2.0.02.22.1

Products include Mantisbt Mantisbt.

How do I fix CVE-2019-15715?

Upgrade mantisbt/mantisbt to a fixed version for your release line: 1.3.20 or 2.22.1.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2019-15715 being exploited?

There is no known exploitation of CVE-2019-15715 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.

All Mantisbt Mantisbt vulnerabilities

Sources

Also known as GHSA-v23g-wjvq-2fpf.

Is CVE-2019-15715 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free