# CVE-2019-15715: MantisBT Remote Code Execution

> An authenticated attacker can inject commands to execute arbitrary code on the server hosting the MantisBT bug tracker.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-v23g-wjvq-2fpf

## What is CVE-2019-15715?

CVE-2019-15715 is a high-severity command injection vulnerability in Mantisbt Mantisbt, published on 9 Oct 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-15715?

4 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 1.3.20 |
| `mantisbt/mantisbt` | Packagist | All versions | 1.3.20 |
| `mantisbt/mantisbt` | Packagist | From 2.0.0 | 2.22.1 |
| `mantisbt/mantisbt` | Packagist | From 2.0.0 | 2.22.1 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2019-15715?

Upgrade mantisbt/mantisbt to a fixed version for your release line: 1.3.20 or 2.22.1.

## Is CVE-2019-15715 being exploited?

There is no known exploitation of CVE-2019-15715 in the wild and no public exploit code.

Public exploit code:

- Mantis Bug Tracker 2.3.0 - Remote Code Execution (Unauthenticated) (exploitdb)
- Replica of CVE-2019-15715 in Python3 (github_poc): https://github.com/mcornaglia/CVE-2019-15715

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15715 and fix it if it is affected.

What it is: CVE-2019-15715 is a high-severity command injection vulnerability in Mantisbt Mantisbt, published on 9 Oct 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15715 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 1.3.20
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 1.3.20
- mantisbt/mantisbt (Packagist): affected from 2.0.0; fixed in 2.22.1
- mantisbt/mantisbt (Packagist): affected from 2.0.0; fixed in 2.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15715/ (Markdown: https://insights.sbomify.com/CVE-2019-15715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15715
- OSV: https://osv.dev/vulnerability/CVE-2019-15715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15715/
Summaries are generated and may contain mistakes; the official description above is the record.
