# CVE-2019-15753: OpenStack os-vif Ageing time of 0 disables linuxbridge MAC learning

> Hard-coded MAC aging in OpenStack os-vif linuxbridge backend causes network flooding, allowing cross-tenant packet sniffing and performance degradation.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-15753, GHSA-mcpw-cp35-p3h8, PYSEC-2026-440, UBUNTU-CVE-2019-15753

## What is CVE-2019-15753?

CVE-2019-15753 is a critical vulnerability in n/a, published on 28 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In OpenStack os-vif 1.15.x before 1.15.2, and 1.16.0, a hard-coded MAC aging time of 0 disables MAC learning in linuxbridge, forcing obligatory Ethernet flooding of non-local destinations, which both impedes network performance and allows users to possibly view the content of packets for instances belonging to other tenants sharing the same network. Only deployments using the linuxbridge backend are affected. This occurs in PyRoute2.add() in internal/command/ip/linux/impl_pyroute2.py.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2019-15753?

5 open source packages ship an affected version, including os-vif. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `os-vif` | PyPI | From 1.15.0 | 1.15.2, 1.17.0 |
| `os-vif` | PyPI | From 1.15.0 | 1.15.2 |
| `os-vif` | PyPI | From 1.15.0 | 1.15.2 |
| `os-vif` | PyPI | From 1.16.0 | 1.17.0 |
| `os-vif` | PyPI | From 1.16.0 | 1.17.0 |

Products: Openstack Os-Vif.

## How do I fix CVE-2019-15753?

Upgrade os-vif to a fixed version for your release line: 1.15.2 or 1.17.0.

## Is CVE-2019-15753 being exploited?

There is no known exploitation of CVE-2019-15753 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15753 and fix it if it is affected.

What it is: CVE-2019-15753 is a critical vulnerability in n/a, published on 28 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15753 in the wild and no public exploit code.

Affected packages and fixed versions:
- os-vif (PyPI): affected from 1.15.0; fixed in 1.15.2, 1.17.0
- os-vif (PyPI): affected from 1.15.0; fixed in 1.15.2
- os-vif (PyPI): affected from 1.15.0; fixed in 1.15.2
- os-vif (PyPI): affected from 1.16.0; fixed in 1.17.0
- os-vif (PyPI): affected from 1.16.0; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15753/ (Markdown: https://insights.sbomify.com/CVE-2019-15753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15753
- OSV: https://osv.dev/vulnerability/CVE-2019-15753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15753/
Summaries are generated and may contain mistakes; the official description above is the record.
