# CVE-2019-15782: Cross-Site Scripting in webtorrent

> An attacker can execute arbitrary scripts in the victim's browser via malicious titles or filenames in the WebTorrent HTTP server.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gjh4-fcv3-whpq

## What is CVE-2019-15782?

CVE-2019-15782 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

WebTorrent before 0.107.6 allows XSS in the HTTP server via a title or file name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-15782?

2 open source packages ship an affected version, including webtorrent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webtorrent` | npm | All versions | 0.107.6 |
| `webtorrent` | npm | All versions | 0.107.6 |

Products: Webtorrent Webtorrent.

## How do I fix CVE-2019-15782?

Upgrade webtorrent to 0.107.6 or later.

## Is CVE-2019-15782 being exploited?

There is no known exploitation of CVE-2019-15782 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15782 and fix it if it is affected.

What it is: CVE-2019-15782 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-15782 in the wild and no public exploit code.

Affected packages and fixed versions:
- webtorrent (npm): affected all versions; fixed in 0.107.6
- webtorrent (npm): affected all versions; fixed in 0.107.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15782/ (Markdown: https://insights.sbomify.com/CVE-2019-15782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15782
- OSV: https://osv.dev/vulnerability/CVE-2019-15782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15782/
Summaries are generated and may contain mistakes; the official description above is the record.
