{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-15784 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-15784 is a critical memory corruption vulnerability in n/a, published on 29 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-15784 and fix it if it is affected.\n\nWhat it is: CVE-2019-15784 is a critical memory corruption vulnerability in n/a, published on 29 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-15784 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-15784/ (Markdown: https://insights.sbomify.com/CVE-2019-15784/index.md)","id":"CVE-2019-15784","markdown":"https://insights.sbomify.com/CVE-2019-15784/index.md","name":"CVE-2019-15784","record":{"aliases":["DEBIAN-CVE-2019-15784","GHSA-f9v4-7rfw-58p4","openSUSE-SU-2019:2083-1","openSUSE-SU-2019:2128-1","openSUSE-SU-2024:11405-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"SRT library","requires_auth":"none","summary":"An array overflow in the SRT library allows attackers to cause denial of service or potentially execute code via numerous connections.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"secure_reliable_transport","vendor":"srtalliance"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"Secure Reliable Transport (SRT) through 1.3.4 has a CSndUList array overflow if there are many SRT connections.","ecosystems":["SUSE:Package Hub 15 SP1","openSUSE:Leap 15.1","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2019-15784","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2019"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2019-15785"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["1.3.4-bp151.3.3.1"],"introduced":["0"],"last_affected":[],"package":"srt","purl":"pkg:rpm/suse/srt\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2019:2128-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["1.3.4-lp151.2.3.1"],"introduced":["0"],"last_affected":[],"package":"srt","purl":"pkg:rpm/opensuse/srt\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2019:2083-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.3-1.3"],"introduced":["0"],"last_affected":[],"package":"srt","purl":"pkg:rpm/opensuse/srt\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11405-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2019-15783"},"products":["n/a"],"published":"2019-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An array overflow in the SRT library allows attackers to cause denial of service or potentially execute code via numerous connections.","url":"https://insights.sbomify.com/CVE-2019-15784/"}