{"answers":{"affected":"10 open source packages ship an affected version, including python-apt. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-15795 in the wild and no public exploit code.","fix":"Upgrade python-apt to a fixed version for your release line: 0.8.3ubuntu7.5, 0.9.3.5ubuntu3, 1.1.0 or 1.6.5ubuntu0.1.","what":"CVE-2019-15795 is a medium-severity vulnerability in Canonical Python-apt, published on 26 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-15795 and fix it if it is affected.\n\nWhat it is: CVE-2019-15795 is a medium-severity vulnerability in Canonical Python-apt, published on 26 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-15795 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- python-apt (PyPI): affected all versions; fixed in 0.8.3ubuntu7.5\n- python-apt (PyPI): affected all versions; fixed in 0.8.3ubuntu7.5\n- python-apt (PyPI): affected from 0.9.0; fixed in 0.9.3.5ubuntu3\n- python-apt (PyPI): affected from 0.9.0; fixed in 0.9.3.5ubuntu3\n- python-apt (PyPI): affected from 1.0.0; fixed in 1.1.0\n- python-apt (PyPI): affected from 1.0.0; fixed in 1.1.0\n- python-apt (PyPI): affected from 1.2.0; fixed in 1.6.5ubuntu0.1\n- python-apt (PyPI): affected from 1.2.0; fixed in 1.6.5ubuntu0.1\n- python-apt (PyPI): affected from 1.7.0; fixed in 1.9.0ubuntu1.2\n- python-apt (PyPI): affected from 1.7.0; fixed in 1.9.0ubuntu1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-15795/ (Markdown: https://insights.sbomify.com/CVE-2019-15795/index.md)","id":"CVE-2019-15795","markdown":"https://insights.sbomify.com/CVE-2019-15795/index.md","name":"CVE-2019-15795","record":{"aliases":["DEBIAN-CVE-2019-15795","GHSA-rp8m-h266-53jh","UBUNTU-CVE-2019-15795"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python APT library","requires_auth":"none","summary":"Man-in-the-middle attackers can install altered packages by exploiting weak MD5 validation in python-apt, requiring users to upgrade the library.","user_interaction":"required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"python-apt","vendor":"debian"},{"product":"python-apt","vendor":"ubuntu"}],"cvss":{"score":4.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"python-apt uses MD5 for validation","id":"CVE-2019-15795","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2019"},"n_packages":10,"n_references":2,"next":{"headline":"python-apt downloads from untrusted sources","id":"CVE-2019-15796"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.3ubuntu7.5"],"introduced":["0"],"last_affected":[],"package":"python-apt","purl":null,"source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["0.8.3ubuntu7.5"],"introduced":["0"],"last_affected":[],"package":"python-apt","purl":"pkg:pypi/python-apt","source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["0.9.3.5ubuntu3"],"introduced":["0.9.0"],"last_affected":[],"package":"python-apt","purl":null,"source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["0.9.3.5ubuntu3"],"introduced":["0.9.0"],"last_affected":[],"package":"python-apt","purl":"pkg:pypi/python-apt","source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["1.0.0"],"last_affected":[],"package":"python-apt","purl":null,"source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["1.0.0"],"last_affected":[],"package":"python-apt","purl":"pkg:pypi/python-apt","source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["1.6.5ubuntu0.1"],"introduced":["1.2.0"],"last_affected":[],"package":"python-apt","purl":null,"source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["1.6.5ubuntu0.1"],"introduced":["1.2.0"],"last_affected":[],"package":"python-apt","purl":"pkg:pypi/python-apt","source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["1.9.0ubuntu1.2"],"introduced":["1.7.0"],"last_affected":[],"package":"python-apt","purl":null,"source":"GHSA-rp8m-h266-53jh"},{"ecosystem":"PyPI","fixed":["1.9.0ubuntu1.2"],"introduced":["1.7.0"],"last_affected":[],"package":"python-apt","purl":"pkg:pypi/python-apt","source":"GHSA-rp8m-h266-53jh"}],"prev":{"headline":"Reference counting error in overlayfs/shiftfs error path when used in conjuction with aufs","id":"CVE-2019-15794"},"products":["Python-apt"],"published":"2020-03-26","related":[{"cvss_score":4.7,"headline":"python-apt downloads from untrusted sources","id":"CVE-2019-15796","kev_date_added":null,"published":"2020-03-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Canonical"]},"summary":"Man-in-the-middle attackers can install altered packages by exploiting weak MD5 validation in python-apt, requiring users to upgrade the library.","url":"https://insights.sbomify.com/CVE-2019-15795/"}