{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-15846 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-15846 is a critical command injection vulnerability in Debian Debian Linux, published on 6 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-15846 and fix it if it is affected.\n\nWhat it is: CVE-2019-15846 is a critical command injection vulnerability in Debian Debian Linux, published on 6 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-15846 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-15846/ (Markdown: https://insights.sbomify.com/CVE-2019-15846/index.md)","id":"CVE-2019-15846","markdown":"https://insights.sbomify.com/CVE-2019-15846/index.md","name":"CVE-2019-15846","record":{"aliases":["CLEANSTART-2025-MR41152","DEBIAN-CVE-2019-15846","DLA-1911-1","DSA-4517-1","GHSA-f368-8x8g-4m4v","UBUNTU-CVE-2019-15846","USN-4124-1","USN-4124-2","openSUSE-SU-2019:2093-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Exim mail server","requires_auth":"none","summary":"Remote attackers can execute arbitrary code as root on Exim mail servers via a trailing backslash vulnerability.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"exim","vendor":"exim"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing backslash.","ecosystems":["openSUSE:Leap 15.0","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":"2019-10-09","github_poc":1,"max_poc_stars":30,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-10-09T15:19:58Z","kind":"github_poc","ref":"https://github.com/synacktiv/Exim-CVE-2019-15846","stars":30,"title":"PoC materials to exploit CVE-2019-15846"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2019-15846","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","exim:exim"],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":23,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2019-15847"},"packages":[{"ecosystem":"openSUSE:Leap 15.0","fixed":["4.88-lp151.4.9.1"],"introduced":["0"],"last_affected":[],"package":"exim","purl":"pkg:rpm/opensuse/exim\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:2093-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["4.88-lp151.4.9.1"],"introduced":["0"],"last_affected":[],"package":"exim","purl":"pkg:rpm/opensuse/exim\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2019:2093-1"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2019-15845"},"products":["n/a"],"published":"2019-09-06","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code as root on Exim mail servers via a trailing backslash vulnerability.","url":"https://insights.sbomify.com/CVE-2019-15846/"}