{"answers":{"affected":"2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-15929 in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to 3.1.7 or later.","what":"CVE-2019-15929 is a critical vulnerability in Craftcms Craft Cms, published on 24 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-15929 and fix it if it is affected.\n\nWhat it is: CVE-2019-15929 is a critical vulnerability in Craftcms Craft Cms, published on 24 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-15929 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected all versions; fixed in 3.1.7\n- craftcms/cms (Packagist): affected all versions; fixed in 3.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-15929/ (Markdown: https://insights.sbomify.com/CVE-2019-15929/index.md)","id":"CVE-2019-15929","markdown":"https://insights.sbomify.com/CVE-2019-15929/index.md","name":"CVE-2019-15929","record":{"aliases":["GHSA-wvr4-w6cw-4px8"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS","requires_auth":"none","summary":"Attackers can brute force elevated session passwords in Craft CMS due to missing rate limits, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"craft_cms","vendor":"craftcms"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-640","name":"Weak Password Recovery Mechanism for Forgotten Password"}],"description":"In Craft CMS through 3.1.7, the elevated session password prompt was not being rate limited like normal login forms, leading to the possibility of a brute force attempt on them.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Craft CMS possibility of brute force attempts","id":"CVE-2019-15929","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"craftcms:craft_cms","products":["craftcms:craft_cms"],"type":"security_feature_bypass","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2019-15930"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.7"],"introduced":["0"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-wvr4-w6cw-4px8"},{"ecosystem":"Packagist","fixed":["3.1.7"],"introduced":["0"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-wvr4-w6cw-4px8"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2019-15927"},"products":["n/a"],"published":"2019-10-24","related":[{"cvss_score":10,"headline":"Craft CMS Code Injection","id":"CVE-2025-32432","kev_date_added":"2026-03-20","published":"2025-04-25"},{"cvss_score":9.3,"headline":"Craft CMS Code Injection","id":"CVE-2024-56145","kev_date_added":"2025-06-02","published":"2024-12-18"},{"cvss_score":8.1,"headline":"Craft CMS Code Injection","id":"CVE-2025-23209","kev_date_added":"2025-02-20","published":"2025-01-18"},{"cvss_score":6.9,"headline":"Craft CMS External Control of Assumed-Immutable Web Parameter","id":"CVE-2025-35939","kev_date_added":"2025-06-02","published":"2025-05-07"},{"cvss_score":10,"headline":"Craft CMS Remote Code Execution vulnerability","id":"CVE-2023-41892","kev_date_added":null,"published":"2023-09-13"},{"cvss_score":9.8,"headline":"Craft CMS Remote Code Injection","id":"CVE-2021-27903","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":9.8,"headline":"SEOmatic for CraftCMS allows Server-Side Template Injection","id":"CVE-2020-9757","kev_date_added":null,"published":"2020-03-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can brute force elevated session passwords in Craft CMS due to missing rate limits, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2019-15929/"}