# CVE-2019-15939: Divide By Zero in OpenCV.

> A divide-by-zero error in OpenCV's HOG descriptor calculation allows attackers to cause a denial of service via crafted input.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-15939, GHSA-hxfw-jm98-v4mq, PYSEC-2026-2799, PYSEC-2026-2822, PYSEC-2026-2838, PYSEC-2026-722, UBUNTU-CVE-2019-15939

## What is CVE-2019-15939?

CVE-2019-15939 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 5 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in OpenCV 4.1.0. There is a divide-by-zero error in cv::HOGDescriptor::getDescriptorSize in modules/objdetect/src/hog.cpp.

Weakness: CWE-369 (Divide By Zero)

## Which versions are affected by CVE-2019-15939?

12 open source packages ship an affected version, including opencv-contrib-python, opencv-contrib-python-headless and opencv-python. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencv-contrib-python` | PyPI | All versions | 4.1.1.26 |
| `opencv-contrib-python` | PyPI | All versions | 4.1.1.26 |
| `opencv-contrib-python` | PyPI | All versions | 4.1.1.26 |
| `opencv-contrib-python-headless` | PyPI | All versions | 4.1.1.26 |
| `opencv-contrib-python-headless` | PyPI | All versions | 4.1.1.26 |
| `opencv-contrib-python-headless` | PyPI | All versions | 4.1.1.26 |
| `opencv-python` | PyPI | All versions | 4.1.1.26 |
| `opencv-python` | PyPI | All versions | 4.1.1.26 |
| `opencv-python` | PyPI | All versions | 4.1.1.26 |
| `opencv-python-headless` | PyPI | All versions | 4.1.1.26 |
| `opencv-python-headless` | PyPI | All versions | 4.1.1.26 |
| `opencv-python-headless` | PyPI | All versions | 4.1.1.26 |

Products: Debian Debian Linux, Opencv Opencv, Opensuse Leap.

## How do I fix CVE-2019-15939?

Upgrade opencv-contrib-python to 4.1.1.26 or later.

## Is CVE-2019-15939 being exploited?

There is no known exploitation of CVE-2019-15939 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15939 and fix it if it is affected.

What it is: CVE-2019-15939 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 5 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15939 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencv-contrib-python (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-contrib-python (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-contrib-python (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-python (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-python (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-python (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-python-headless (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-python-headless (PyPI): affected all versions; fixed in 4.1.1.26
- opencv-python-headless (PyPI): affected all versions; fixed in 4.1.1.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15939/ (Markdown: https://insights.sbomify.com/CVE-2019-15939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15939
- OSV: https://osv.dev/vulnerability/CVE-2019-15939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15939/
Summaries are generated and may contain mistakes; the official description above is the record.
