{"answers":{"affected":"2 open source packages ship an affected version, including airbrake-ruby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16060 in the wild and no public exploit code.","fix":"Upgrade airbrake-ruby to 4.2.4 or later.","what":"CVE-2019-16060 is a critical vulnerability in n/a, published on 6 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16060 and fix it if it is affected.\n\nWhat it is: CVE-2019-16060 is a critical vulnerability in n/a, published on 6 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16060 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- airbrake-ruby (RubyGems): affected from 4.2.3; fixed in 4.2.4\n- airbrake-ruby (RubyGems): affected from 4.2.3; fixed in 4.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16060/ (Markdown: https://insights.sbomify.com/CVE-2019-16060/index.md)","id":"CVE-2019-16060","markdown":"https://insights.sbomify.com/CVE-2019-16060/index.md","name":"CVE-2019-16060","record":{"aliases":["GHSA-2p82-v77v-mppr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby error tracking library","requires_auth":"none","summary":"The Airbrake Ruby notifier may disclose passwords to unauthorized actors if the blacklist_keys configuration option is mishandled.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"airbrake_ruby","vendor":"airbrake"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"The Airbrake Ruby notifier 4.2.3 for Airbrake mishandles the blacklist_keys configuration option and consequently may disclose passwords to unauthorized actors. This is fixed in 4.2.4 (also, 4.2.2 and earlier are unaffected).","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Airbrake keys not being filtered","id":"CVE-2019-16060","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Misconfiguration in n/a","id":"CVE-2019-16061"},"packages":[{"ecosystem":"RubyGems","fixed":["4.2.4"],"introduced":["4.2.3"],"last_affected":[],"package":"airbrake-ruby","purl":null,"source":"GHSA-2p82-v77v-mppr"},{"ecosystem":"RubyGems","fixed":["4.2.4"],"introduced":["4.2.3"],"last_affected":[],"package":"airbrake-ruby","purl":"pkg:gem/airbrake-ruby","source":"GHSA-2p82-v77v-mppr"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2019-16059"},"products":["n/a"],"published":"2019-09-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"The Airbrake Ruby notifier may disclose passwords to unauthorized actors if the blacklist_keys configuration option is mishandled.","url":"https://insights.sbomify.com/CVE-2019-16060/"}