# CVE-2019-16060: Airbrake keys not being filtered

> The Airbrake Ruby notifier may disclose passwords to unauthorized actors if the blacklist_keys configuration option is mishandled.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2p82-v77v-mppr

## What is CVE-2019-16060?

CVE-2019-16060 is a critical vulnerability in n/a, published on 6 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Airbrake Ruby notifier 4.2.3 for Airbrake mishandles the blacklist_keys configuration option and consequently may disclose passwords to unauthorized actors. This is fixed in 4.2.4 (also, 4.2.2 and earlier are unaffected).

## Which versions are affected by CVE-2019-16060?

2 open source packages ship an affected version, including airbrake-ruby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `airbrake-ruby` | RubyGems | From 4.2.3 | 4.2.4 |
| `airbrake-ruby` | RubyGems | From 4.2.3 | 4.2.4 |

Products: Airbrake Airbrake Ruby.

## How do I fix CVE-2019-16060?

Upgrade airbrake-ruby to 4.2.4 or later.

## Is CVE-2019-16060 being exploited?

There is no known exploitation of CVE-2019-16060 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16060 and fix it if it is affected.

What it is: CVE-2019-16060 is a critical vulnerability in n/a, published on 6 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16060 in the wild and no public exploit code.

Affected packages and fixed versions:
- airbrake-ruby (RubyGems): affected from 4.2.3; fixed in 4.2.4
- airbrake-ruby (RubyGems): affected from 4.2.3; fixed in 4.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16060/ (Markdown: https://insights.sbomify.com/CVE-2019-16060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16060
- OSV: https://osv.dev/vulnerability/CVE-2019-16060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16060/
Summaries are generated and may contain mistakes; the official description above is the record.
