# CVE-2019-16097: Missing Authorization in Harbor

> Non-admin users can create admin accounts in Harbor when using DB authentication with self-registration enabled, allowing full system compromise.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9wvh-ff5f-xjpj, GO-2022-0818

## What is CVE-2019-16097?

CVE-2019-16097 is a medium-severity vulnerability in n/a, published on 8 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

core/api/user.go in Harbor 1.7.0 through 1.8.2 allows non-admin users to create admin accounts via the POST /api/users API, when Harbor is setup with DB as authentication backend and allow user to do self-registration. Fixed version: v1.7.6 v1.8.3. v.1.9.0. Workaround without applying the fix: configure Harbor to use non-DB authentication backend such as LDAP.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-16097?

3 open source packages ship an affected version, including github.com/goharbor/harbor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/goharbor/harbor` | Go | From 1.7.0 | 1.9.0-rc1 |
| `github.com/goharbor/harbor` | Go | From 1.7.0 | 1.9.0-rc1 |
| `github.com/goharbor/harbor` | Go | From 1.7.0 | 1.9.0-rc1 |

Products: Linuxfoundation Harbor.

## How do I fix CVE-2019-16097?

Upgrade github.com/goharbor/harbor to 1.9.0-rc1 or later.

## Is CVE-2019-16097 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-16097 exists.

Public exploit code:

- CVE-2019-16097 PoC (github_poc): https://github.com/evilAdan0s/CVE-2019-16097
- CVE-2019-16097-batch (github_poc): https://github.com/rockmelodies/CVE-2019-16097-batch
- Harbor 未授权创建管理员漏洞原理 docker及poc[基于pocsuite框架] (github_poc): https://github.com/luckybool1020/CVE-2019-16097
- cve-2019-1609 (github_poc): https://github.com/dacade/cve-2019-16097
- https://github.com/ianxtianxt/CVE-2019-16097 (github_poc): https://github.com/ianxtianxt/CVE-2019-16097
- harbor(<1.7.6/1.8.3) privilege escalation (CVE-2019-16097) (github_poc): https://github.com/theLSA/harbor-give-me-admin

## Other vulnerabilities in n/a

- [CVE-2026-4404](https://insights.sbomify.com/CVE-2026-4404/): Use of hard coded credentials in GoHarbor Harbor (critical 9.4)
- [CVE-2019-19023](https://insights.sbomify.com/CVE-2019-19023/): Privilege Escalation in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2019-19025](https://insights.sbomify.com/CVE-2019-19025/): Cross-site Request Forgery (CSRF) in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2017-17697](https://insights.sbomify.com/CVE-2017-17697/): Server-side request forgery in n/a (high 8.6)
- [CVE-2022-31666](https://insights.sbomify.com/CVE-2022-31666/): Harbor fails to validate user permissions while Viewing, updating and deleting Webhook policies (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16097 and fix it if it is affected.

What it is: CVE-2019-16097 is a medium-severity vulnerability in n/a, published on 8 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-16097 exists.

Affected packages and fixed versions:
- github.com/goharbor/harbor (Go): affected from 1.7.0; fixed in 1.9.0-rc1
- github.com/goharbor/harbor (Go): affected from 1.7.0; fixed in 1.9.0-rc1
- github.com/goharbor/harbor (Go): affected from 1.7.0; fixed in 1.9.0-rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16097/ (Markdown: https://insights.sbomify.com/CVE-2019-16097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16097
- OSV: https://osv.dev/vulnerability/CVE-2019-16097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16097/
Summaries are generated and may contain mistakes; the official description above is the record.
