# CVE-2019-16108: phpBB arbitrary CSS injection

> Attackers can inject arbitrary CSS tokens via BBCode in phpBB, potentially leading to code execution or style manipulation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8hc2-hvrc-x4qr

## What is CVE-2019-16108?

CVE-2019-16108 is a high-severity code injection vulnerability in n/a, published on 19 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-16108?

2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | From 3.2.7 | 3.2.8 |
| `phpbb/phpbb` | Packagist | From 3.2.7 | 3.2.8 |

Products: Phpbb Phpbb.

## How do I fix CVE-2019-16108?

Upgrade phpbb/phpbb to 3.2.8 or later.

## Is CVE-2019-16108 being exploited?

There is no known exploitation of CVE-2019-16108 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-3224](https://insights.sbomify.com/CVE-2008-3224/): Other in n/a (critical 10.0)
- [CVE-2008-1766](https://insights.sbomify.com/CVE-2008-1766/): Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bu (critical 10.0)
- [CVE-2025-70810](https://insights.sbomify.com/CVE-2025-70810/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2001-1471](https://insights.sbomify.com/CVE-2001-1471/): Code injection in n/a (high 8.8)
- [CVE-2026-29199](https://insights.sbomify.com/CVE-2026-29199/): phpBB has Password Reset Link Poisoning via Host Header injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16108 and fix it if it is affected.

What it is: CVE-2019-16108 is a high-severity code injection vulnerability in n/a, published on 19 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16108 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected from 3.2.7; fixed in 3.2.8
- phpbb/phpbb (Packagist): affected from 3.2.7; fixed in 3.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16108/ (Markdown: https://insights.sbomify.com/CVE-2019-16108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16108
- OSV: https://osv.dev/vulnerability/CVE-2019-16108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16108/
Summaries are generated and may contain mistakes; the official description above is the record.
