# CVE-2019-16109: Authentication Bypass in Devise

> Attackers can bypass account confirmation if database records have blank tokens, potentially taking over accounts in Devise Ruby library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-fcjw-8rhj-gwwc, UBUNTU-CVE-2019-16109

## What is CVE-2019-16109?

CVE-2019-16109 is a medium-severity authentication bypass vulnerability in n/a, published on 8 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Plataformatec Devise before 4.7.1. It confirms accounts upon receiving a request with a blank confirmation_token, if a database record has a blank value in the confirmation_token column. (However, there is no scenario within Devise itself in which such database records would exist.)

## Which versions are affected by CVE-2019-16109?

2 open source packages ship an affected version, including devise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devise` | RubyGems | All versions | 4.7.1 |
| `devise` | RubyGems | All versions | 4.7.1 |

Products: Plataformatec Devise.

## How do I fix CVE-2019-16109?

Upgrade devise to 4.7.1 or later.

## Is CVE-2019-16109 being exploited?

There is no known exploitation of CVE-2019-16109 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-5421](https://insights.sbomify.com/CVE-2019-5421/): devise Time-of-check Time-of-use Race Condition vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16109 and fix it if it is affected.

What it is: CVE-2019-16109 is a medium-severity authentication bypass vulnerability in n/a, published on 8 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16109 in the wild and no public exploit code.

Affected packages and fixed versions:
- devise (RubyGems): affected all versions; fixed in 4.7.1
- devise (RubyGems): affected all versions; fixed in 4.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16109/ (Markdown: https://insights.sbomify.com/CVE-2019-16109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16109
- OSV: https://osv.dev/vulnerability/CVE-2019-16109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16109/
Summaries are generated and may contain mistakes; the official description above is the record.
