# CVE-2019-16126: Cross-site Scripting in Grav

> Attackers can execute arbitrary JavaScript in victims' browsers via stored XSS in SVG images, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6268-v434-45m5

## What is CVE-2019-16126?

CVE-2019-16126 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Grav through 1.6.15 allows (Stored) Cross-Site Scripting due to JavaScript execution in SVG images.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-16126?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.0-beta.8 |
| `getgrav/grav` | Packagist | All versions | 1.7.0-beta.8 |

Products: Getgrav Grav Cms.

## How do I fix CVE-2019-16126?

Upgrade getgrav/grav to 1.7.0-beta.8 or later.

## Is CVE-2019-16126 being exploited?

There is no known exploitation of CVE-2019-16126 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-29553](https://insights.sbomify.com/CVE-2020-29553/): Grav CMS Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2020-29555](https://insights.sbomify.com/CVE-2020-29555/): Grav CMS Arbitrary File Deletion (high 8.1)
- [CVE-2018-5233](https://insights.sbomify.com/CVE-2018-5233/): Grav CMS Cross-site scripting (XSS) vulnerability (medium 6.1)
- [CVE-2020-29556](https://insights.sbomify.com/CVE-2020-29556/): Grav CMS Local File Injection (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16126 and fix it if it is affected.

What it is: CVE-2019-16126 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16126 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.0-beta.8
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.0-beta.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16126/ (Markdown: https://insights.sbomify.com/CVE-2019-16126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16126
- OSV: https://osv.dev/vulnerability/CVE-2019-16126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16126/
Summaries are generated and may contain mistakes; the official description above is the record.
