{"answers":{"affected":"2 open source packages ship an affected version, including yii2mod/yii2-cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16130 in the wild and no public exploit code.","fix":"Upgrade yii2mod/yii2-cms to 1.9.2 or later.","what":"CVE-2019-16130 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16130 and fix it if it is affected.\n\nWhat it is: CVE-2019-16130 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16130 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yii2mod/yii2-cms (Packagist): affected all versions; fixed in 1.9.2\n- yii2mod/yii2-cms (Packagist): affected all versions; fixed in 1.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16130/ (Markdown: https://insights.sbomify.com/CVE-2019-16130/index.md)","id":"CVE-2019-16130","markdown":"https://insights.sbomify.com/CVE-2019-16130/index.md","name":"CVE-2019-16130","record":{"aliases":["GHSA-rfh8-25h9-mhgf"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"YII2-CMS","requires_auth":"none","summary":"Cross-site scripting vulnerability in YII2-CMS allows attackers to inject malicious scripts via the contact form name field.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yii-cms","vendor":"hgw168cc"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"YII2-CMS v1.0 has XSS in protected\\core\\modules\\home\\models\\Contact.php via a name field to /contact.html.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in YII2-CMS","id":"CVE-2019-16130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"File upload in n/a","id":"CVE-2019-16131"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"yii2mod/yii2-cms","purl":null,"source":"GHSA-rfh8-25h9-mhgf"},{"ecosystem":"Packagist","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"yii2mod/yii2-cms","purl":"pkg:composer/yii2mod/yii2-cms","source":"GHSA-rfh8-25h9-mhgf"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2019-16129"},"products":["n/a"],"published":"2019-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in YII2-CMS allows attackers to inject malicious scripts via the contact form name field.","url":"https://insights.sbomify.com/CVE-2019-16130/"}