# CVE-2019-16130: Cross-site Scripting in YII2-CMS

> Cross-site scripting vulnerability in YII2-CMS allows attackers to inject malicious scripts via the contact form name field.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rfh8-25h9-mhgf

## What is CVE-2019-16130?

CVE-2019-16130 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YII2-CMS v1.0 has XSS in protected\core\modules\home\models\Contact.php via a name field to /contact.html.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-16130?

2 open source packages ship an affected version, including yii2mod/yii2-cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yii2mod/yii2-cms` | Packagist | All versions | 1.9.2 |
| `yii2mod/yii2-cms` | Packagist | All versions | 1.9.2 |

Products: Hgw168cc Yii-Cms.

## How do I fix CVE-2019-16130?

Upgrade yii2mod/yii2-cms to 1.9.2 or later.

## Is CVE-2019-16130 being exploited?

There is no known exploitation of CVE-2019-16130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16130 and fix it if it is affected.

What it is: CVE-2019-16130 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16130 in the wild and no public exploit code.

Affected packages and fixed versions:
- yii2mod/yii2-cms (Packagist): affected all versions; fixed in 1.9.2
- yii2mod/yii2-cms (Packagist): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16130/ (Markdown: https://insights.sbomify.com/CVE-2019-16130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16130
- OSV: https://osv.dev/vulnerability/CVE-2019-16130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16130/
Summaries are generated and may contain mistakes; the official description above is the record.
