# CVE-2019-16138: Use after free in image

> A use-after-free vulnerability in the Rust image crate's HDR decoder allows attackers to execute arbitrary code via malicious images.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m2pf-hprp-3vqm, RUSTSEC-2019-0014

## What is CVE-2019-16138?

CVE-2019-16138 is a critical use after free vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the image crate before 0.21.3 for Rust, affecting the HDR image format decoder. Vec::set_len is called on an uninitialized vector, leading to a use-after-free and arbitrary code execution.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2019-16138?

3 open source packages ship an affected version, including image. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `image` | crates.io | From 0.10.2 | 0.21.3 |
| `image` | crates.io | From 0.10.2 | 0.21.3 |
| `image` | crates.io | From 0.10.2 | 0.21.3 |

Products: Image-Rs Image.

## How do I fix CVE-2019-16138?

Upgrade image to 0.21.3 or later.

## Is CVE-2019-16138 being exploited?

There is no known exploitation of CVE-2019-16138 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-35916](https://insights.sbomify.com/CVE-2020-35916/): Mutable reference with immutable provenance in image (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16138 and fix it if it is affected.

What it is: CVE-2019-16138 is a critical use after free vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16138 in the wild and no public exploit code.

Affected packages and fixed versions:
- image (crates.io): affected from 0.10.2; fixed in 0.21.3
- image (crates.io): affected from 0.10.2; fixed in 0.21.3
- image (crates.io): affected from 0.10.2; fixed in 0.21.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16138/ (Markdown: https://insights.sbomify.com/CVE-2019-16138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16138
- OSV: https://osv.dev/vulnerability/CVE-2019-16138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16138/
Summaries are generated and may contain mistakes; the official description above is the record.
