# CVE-2019-16139: Out of bounds access in compact_arena

> Attackers can trigger out-of-bounds memory access in the compact_arena Rust library, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7j36-gc4r-9x3r, RUSTSEC-2019-0015

## What is CVE-2019-16139?

CVE-2019-16139 is a critical memory corruption vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the compact_arena crate before 0.4.0 for Rust. Generativity is mishandled, leading to an out-of-bounds write or read.

Weakness: CWE-787 (Out-of-bounds Write), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2019-16139?

3 open source packages ship an affected version, including compact_arena. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `compact_arena` | crates.io | All versions | 0.4.0 |
| `compact_arena` | crates.io | All versions | 0.4.0 |
| `compact_arena` | crates.io | From 0.0.0-0 | 0.4.0 |

Products: Compact Arena Project Compact Arena.

## How do I fix CVE-2019-16139?

Upgrade compact_arena to 0.4.0 or later.

## Is CVE-2019-16139 being exploited?

There is no known exploitation of CVE-2019-16139 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16139 and fix it if it is affected.

What it is: CVE-2019-16139 is a critical memory corruption vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16139 in the wild and no public exploit code.

Affected packages and fixed versions:
- compact_arena (crates.io): affected all versions; fixed in 0.4.0
- compact_arena (crates.io): affected all versions; fixed in 0.4.0
- compact_arena (crates.io): affected from 0.0.0-0; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16139/ (Markdown: https://insights.sbomify.com/CVE-2019-16139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16139
- OSV: https://osv.dev/vulnerability/CVE-2019-16139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16139/
Summaries are generated and may contain mistakes; the official description above is the record.
