{"answers":{"affected":"3 open source packages ship an affected version, including chttp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16140 in the wild and no public exploit code.","fix":"Upgrade chttp to 0.1.3 or later.","what":"CVE-2019-16140 is a critical use after free vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16140 and fix it if it is affected.\n\nWhat it is: CVE-2019-16140 is a critical use after free vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16140 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- chttp (crates.io): affected from 0.1.1; fixed in 0.1.3\n- chttp (crates.io): affected from 0.1.1; fixed in 0.1.3\n- chttp (crates.io): affected from 0.1.1; fixed in 0.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16140/ (Markdown: https://insights.sbomify.com/CVE-2019-16140/index.md)","id":"CVE-2019-16140","markdown":"https://insights.sbomify.com/CVE-2019-16140/index.md","name":"CVE-2019-16140","record":{"aliases":["GHSA-5rrv-m36h-qwf8","RUSTSEC-2019-0016"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust HTTP library","requires_auth":"none","summary":"A use-after-free vulnerability in the chttp Rust library allows attackers to potentially execute arbitrary code or cause a denial of service.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"isahc","vendor":"isahc_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"An issue was discovered in the chttp crate before 0.1.3 for Rust. There is a use-after-free during buffer conversion.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use-after-free in chttp","id":"CVE-2019-16140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"use_after_free","year":"2019"},"n_packages":3,"n_references":2,"next":{"headline":"Improper Input Validation in once_cell","id":"CVE-2019-16141"},"packages":[{"ecosystem":"crates.io","fixed":["0.1.3"],"introduced":["0.1.1"],"last_affected":[],"package":"chttp","purl":null,"source":"GHSA-5rrv-m36h-qwf8"},{"ecosystem":"crates.io","fixed":["0.1.3"],"introduced":["0.1.1"],"last_affected":[],"package":"chttp","purl":"pkg:cargo/chttp","source":"GHSA-5rrv-m36h-qwf8"},{"ecosystem":"crates.io","fixed":["0.1.3"],"introduced":["0.1.1"],"last_affected":[],"package":"chttp","purl":"pkg:cargo/chttp","source":"RUSTSEC-2019-0016"}],"prev":{"headline":"Out of bounds access in compact_arena","id":"CVE-2019-16139"},"products":["n/a"],"published":"2019-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A use-after-free vulnerability in the chttp Rust library allows attackers to potentially execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2019-16140/"}