# CVE-2019-16143: Algorithms compute incorrect results in blake2

> The Rust blake2 crate produces incorrect HMAC results due to wrong block sizes, compromising cryptographic integrity for users of the library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4x25-pvhw-5224, RUSTSEC-2019-0019

## What is CVE-2019-16143?

CVE-2019-16143 is a critical vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the blake2 crate before 0.8.1 for Rust. The BLAKE2b and BLAKE2s algorithms, when used with HMAC, produce incorrect results because the block sizes are half of the required sizes.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2019-16143?

3 open source packages ship an affected version, including blake2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `blake2` | crates.io | All versions | 0.8.1 |
| `blake2` | crates.io | All versions | 0.8.1 |
| `blake2` | crates.io | From 0.0.0-0 | 0.8.1 |

Products: Blake2 Blake2-Rust.

## How do I fix CVE-2019-16143?

Upgrade blake2 to 0.8.1 or later.

## Is CVE-2019-16143 being exploited?

There is no known exploitation of CVE-2019-16143 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16143 and fix it if it is affected.

What it is: CVE-2019-16143 is a critical vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16143 in the wild and no public exploit code.

Affected packages and fixed versions:
- blake2 (crates.io): affected all versions; fixed in 0.8.1
- blake2 (crates.io): affected all versions; fixed in 0.8.1
- blake2 (crates.io): affected from 0.0.0-0; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16143/ (Markdown: https://insights.sbomify.com/CVE-2019-16143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16143
- OSV: https://osv.dev/vulnerability/CVE-2019-16143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16143/
Summaries are generated and may contain mistakes; the official description above is the record.
