# CVE-2019-16144: Uninitialized memory use in generator

> Attackers can exploit uninitialized memory in the Rust generator crate to potentially disclose sensitive data or execute arbitrary code.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6c65-xcf5-299x, RUSTSEC-2019-0020

## What is CVE-2019-16144?

CVE-2019-16144 is a high-severity memory corruption vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the generator crate before 0.6.18 for Rust. Uninitialized memory is used by Scope, done, and yield_ during API calls.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2019-16144?

3 open source packages ship an affected version, including generator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `generator` | crates.io | All versions | 0.6.18 |
| `generator` | crates.io | All versions | 0.6.18 |
| `generator` | crates.io | From 0.0.0-0 | 0.6.18 |

Products: Generator-Rs Project Generator-Rs.

## How do I fix CVE-2019-16144?

Upgrade generator to 0.6.18 or later.

## Is CVE-2019-16144 being exploited?

There is no known exploitation of CVE-2019-16144 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16144 and fix it if it is affected.

What it is: CVE-2019-16144 is a high-severity memory corruption vulnerability in n/a, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16144 in the wild and no public exploit code.

Affected packages and fixed versions:
- generator (crates.io): affected all versions; fixed in 0.6.18
- generator (crates.io): affected all versions; fixed in 0.6.18
- generator (crates.io): affected from 0.0.0-0; fixed in 0.6.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16144/ (Markdown: https://insights.sbomify.com/CVE-2019-16144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16144
- OSV: https://osv.dev/vulnerability/CVE-2019-16144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16144/
Summaries are generated and may contain mistakes; the official description above is the record.
