# CVE-2019-16173: Cross-site Scripting in LimeSurvey

> Reflected XSS in LimeSurvey allows low-privileged users to escalate privileges to SuperAdmin, requiring an upgrade to secure the application.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-r5f2-4wf4-cv66

## What is CVE-2019-16173?

CVE-2019-16173 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 9 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LimeSurvey before v3.17.14 allows reflected XSS for escalating privileges from a low-privileged account to, for example, SuperAdmin. This occurs in application/core/Survey_Common_Action.php,

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-16173?

2 open source packages ship an affected version, including limesurvey/limesurvey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limesurvey/limesurvey` | Packagist | All versions | 3.17.14 |
| `limesurvey/limesurvey` | Packagist | All versions | 3.17.14 |

Products: Limesurvey Limesurvey.

## How do I fix CVE-2019-16173?

Upgrade limesurvey/limesurvey to 3.17.14 or later.

## Is CVE-2019-16173 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-16173 exists.

Public exploit code:

- LimeSurvey 3.17.13 - Cross-Site Scripting (exploitdb)

## Other vulnerabilities in Limesurvey Limesurvey

- [CVE-2025-56422](https://insights.sbomify.com/CVE-2025-56422/): Deserialization in n/a (critical 9.8)
- [CVE-2022-48008](https://insights.sbomify.com/CVE-2022-48008/): File upload in n/a (critical 9.8)
- [CVE-2019-25019](https://insights.sbomify.com/CVE-2019-25019/): SQL injection in n/a (critical 9.8)
- [CVE-2020-11455](https://insights.sbomify.com/CVE-2020-11455/): Path traversal in n/a (critical 9.8)
- [CVE-2019-16184](https://insights.sbomify.com/CVE-2019-16184/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16173 and fix it if it is affected.

What it is: CVE-2019-16173 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 9 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-16173 exists.

Affected packages and fixed versions:
- limesurvey/limesurvey (Packagist): affected all versions; fixed in 3.17.14
- limesurvey/limesurvey (Packagist): affected all versions; fixed in 3.17.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16173/ (Markdown: https://insights.sbomify.com/CVE-2019-16173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16173
- OSV: https://osv.dev/vulnerability/CVE-2019-16173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16173/
Summaries are generated and may contain mistakes; the official description above is the record.
