# CVE-2019-16197: Cross-site scripting in Dolibarr

> Attackers can inject malicious scripts via the User-Agent header in Dolibarr, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m553-9wmx-533h, UBUNTU-CVE-2019-16197

## What is CVE-2019-16197?

CVE-2019-16197 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 16 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In htdocs/societe/card.php in Dolibarr 10.0.1, the value of the User-Agent HTTP header is copied into the HTML document as plain text between tags, leading to XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-16197?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 10.0.2 |
| `dolibarr/dolibarr` | Packagist | All versions | 10.0.2 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2019-16197?

Upgrade dolibarr/dolibarr to 10.0.2 or later.

## Is CVE-2019-16197 being exploited?

There is no known exploitation of CVE-2019-16197 in the wild and no public exploit code.

Public exploit code:

- Dolibarr ERP-CRM 10.0.1 - 'User-Agent' Cross-Site Scripting (exploitdb)

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16197 and fix it if it is affected.

What it is: CVE-2019-16197 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 16 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16197 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 10.0.2
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 10.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16197/ (Markdown: https://insights.sbomify.com/CVE-2019-16197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16197
- OSV: https://osv.dev/vulnerability/CVE-2019-16197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16197/
Summaries are generated and may contain mistakes; the official description above is the record.
