# CVE-2019-16227: py-lmdb Invalid write operation

> An attacker can trigger memory corruption in the py-lmdb library by providing a malicious database file, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-16227, ECHO-e174-ee41-e2ae, GHSA-pf3p-v9xp-mrvf, PYSEC-2019-239, UBUNTU-CVE-2019-16227

## What is CVE-2019-16227?

CVE-2019-16227 is a critical memory corruption vulnerability in n/a, published on 11 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in py-lmdb 0.97. For certain values of mn_flags, mdb_cursor_set triggers a memcpy with an invalid write operation within mdb_xcursor_init1. NOTE: this outcome occurs when accessing a data.mdb file supplied by an attacker.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2019-16227?

3 open source packages ship an affected version, including lmdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lmdb` | PyPI | All versions to 0.97 | None |
| `lmdb` | PyPI | All versions to 0.97 | None |
| `lmdb` | PyPI | All versions | 0.98 |

Products: Py-Lmdb Project Py-Lmdb.

## How do I fix CVE-2019-16227?

Upgrade lmdb to 0.98 or later.

## Is CVE-2019-16227 being exploited?

There is no known exploitation of CVE-2019-16227 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-16224](https://insights.sbomify.com/CVE-2019-16224/): py-lmdb Invalid write operation (critical 9.8)
- [CVE-2019-16225](https://insights.sbomify.com/CVE-2019-16225/): py-lmdb Invalid write operation (critical 9.8)
- [CVE-2019-16226](https://insights.sbomify.com/CVE-2019-16226/): LMDB invalid write (high 7.5)
- [CVE-2019-16228](https://insights.sbomify.com/CVE-2019-16228/): py-lmdb Divide by Zero interruptions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16227 and fix it if it is affected.

What it is: CVE-2019-16227 is a critical memory corruption vulnerability in n/a, published on 11 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16227 in the wild and no public exploit code.

Affected packages and fixed versions:
- lmdb (PyPI): affected all versions up to 0.97; no fix listed
- lmdb (PyPI): affected all versions up to 0.97; no fix listed
- lmdb (PyPI): affected all versions; fixed in 0.98

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16227/ (Markdown: https://insights.sbomify.com/CVE-2019-16227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16227
- OSV: https://osv.dev/vulnerability/CVE-2019-16227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16227/
Summaries are generated and may contain mistakes; the official description above is the record.
