# CVE-2019-16249: Out-of-bounds Read in OpenCV

> An out-of-bounds read in OpenCV's video module can cause application crashes or leak sensitive memory contents.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x3rm-644h-67m8, PYSEC-2026-2803, PYSEC-2026-2833, PYSEC-2026-2842, PYSEC-2026-726, UBUNTU-CVE-2019-16249

## What is CVE-2019-16249?

CVE-2019-16249 is a medium-severity memory corruption vulnerability in n/a, published on 11 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenCV 4.1.1 has an out-of-bounds read in hal_baseline::v_load in core/hal/intrin_sse.hpp when called from computeSSDMeanNorm in modules/video/src/dis_flow.cpp.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2019-16249?

12 open source packages ship an affected version, including opencv-contrib-python, opencv-contrib-python-headless and opencv-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencv-contrib-python` | PyPI | All versions | 4.1.2.30 |
| `opencv-contrib-python` | PyPI | All versions | 4.1.2.30 |
| `opencv-contrib-python` | PyPI | All versions | 4.1.2.30 |
| `opencv-contrib-python-headless` | PyPI | All versions | 4.1.2.30 |
| `opencv-contrib-python-headless` | PyPI | All versions | 4.1.2.30 |
| `opencv-contrib-python-headless` | PyPI | All versions | 4.1.2.30 |
| `opencv-python` | PyPI | All versions | 4.1.2.30 |
| `opencv-python` | PyPI | All versions | 4.1.2.30 |
| `opencv-python` | PyPI | All versions | 4.1.2.30 |
| `opencv-python-headless` | PyPI | All versions | 4.1.2.30 |
| `opencv-python-headless` | PyPI | All versions | 4.1.2.30 |
| `opencv-python-headless` | PyPI | All versions | 4.1.2.30 |

Products: Opencv Opencv.

## How do I fix CVE-2019-16249?

Upgrade opencv-contrib-python to 4.1.2.30 or later.

## Is CVE-2019-16249 being exploited?

There is no known exploitation of CVE-2019-16249 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-5063](https://insights.sbomify.com/CVE-2019-5063/): Out-of-bounds Write in OpenCV (high 8.8)
- [CVE-2019-5064](https://insights.sbomify.com/CVE-2019-5064/): Out-of-bounds Write in OpenCV (high 8.8)
- [CVE-2019-14491](https://insights.sbomify.com/CVE-2019-14491/): Out-of-bounds Read in OpenCV (high 8.2)
- [CVE-2019-14492](https://insights.sbomify.com/CVE-2019-14492/): Out-of-bounds Read and Out-of-bounds Write in OpenCV (high 7.5)
- [CVE-2018-7712](https://insights.sbomify.com/CVE-2018-7712/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16249 and fix it if it is affected.

What it is: CVE-2019-16249 is a medium-severity memory corruption vulnerability in n/a, published on 11 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16249 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencv-contrib-python (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-contrib-python (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-contrib-python (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-python (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-python (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-python (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-python-headless (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-python-headless (PyPI): affected all versions; fixed in 4.1.2.30
- opencv-python-headless (PyPI): affected all versions; fixed in 4.1.2.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16249/ (Markdown: https://insights.sbomify.com/CVE-2019-16249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16249
- OSV: https://osv.dev/vulnerability/CVE-2019-16249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16249/
Summaries are generated and may contain mistakes; the official description above is the record.
