# CVE-2019-16276: Other in n/a

> An HTTP Request Smuggling vulnerability in the Go standard library allows attackers to bypass security controls or poison caches.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DSA-4534-1, GHSA-xv7j-jr8q-mhmm, GO-2022-0212, RHBA-2019:3304, UBUNTU-CVE-2019-16276

## What is CVE-2019-16276?

CVE-2019-16276 is a high-severity vulnerability in Debian Debian Linux, published on 30 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Go before 1.12.10 and 1.13.x before 1.13.1 allow HTTP Request Smuggling.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2019-16276?

1 open source package ship an affected version, including stdlib. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stdlib` | Go | All versions | 1.12.10, 1.13.1 |
| `atomic-enterprise-service-catalog` | Red Hat:openshift:4.2::el7 | All versions | 1:4.2.4-201911041319.git.1.1de4bcd.el7 |
| `atomic-enterprise-service-catalog-svcat` | Red Hat:openshift:4.2::el7 | All versions | 1:4.2.4-201911041319.git.1.1de4bcd.el7 |
| `atomic-openshift-service-idler` | Red Hat:openshift:4.2::el7 | All versions | 0:4.2.4-201911041319.git.1.4131c2f.el7 |
| `openshift` | Red Hat:openshift:4.2::el7 | All versions | 0:4.2.4-201911041319.git.0.c7d2111.el7 |
| `openshift-clients` | Red Hat:openshift:4.2::el7 | All versions | 0:4.2.4-201911010432.git.1.30c33a5.el7 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.2::el7 | All versions | 0:4.2.4-201911010432.git.1.30c33a5.el7 |
| `openshift-enterprise-autoheal` | Red Hat:openshift:4.2::el7 | All versions | 0:4.2.4-201911010432.git.1.0b5cd44.el7 |
| `openshift-hyperkube` | Red Hat:openshift:4.2::el7 | All versions | 0:4.2.4-201911041319.git.0.c7d2111.el7 |
| `openshift` | Red Hat:openshift:4.2::el8 | All versions | 0:4.2.4-201911041319.git.0.c7d2111.el8 |
| `openshift-clients` | Red Hat:openshift:4.2::el8 | All versions | 0:4.2.4-201911010432.git.1.30c33a5.el8 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.2::el8 | All versions | 0:4.2.4-201911010432.git.1.30c33a5.el8 |
| `openshift-hyperkube` | Red Hat:openshift:4.2::el8 | All versions | 0:4.2.4-201911041319.git.0.c7d2111.el8 |

Products: Debian Debian Linux, Fedoraproject Fedora, Golang Go, Netapp Cloud Insights Telegraf Agent, Opensuse Leap, Redhat Developer Tools, Redhat Enterprise Linux, Redhat Enterprise Linux Eus, Redhat Openshift Container Platform.

## How do I fix CVE-2019-16276?

Upgrade stdlib to a fixed version for your release line: 1.12.10 or 1.13.1.

## Is CVE-2019-16276 being exploited?

There is no known exploitation of CVE-2019-16276 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16276 and fix it if it is affected.

What it is: CVE-2019-16276 is a high-severity vulnerability in Debian Debian Linux, published on 30 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16276 in the wild and no public exploit code.

Affected packages and fixed versions:
- stdlib (Go): affected all versions; fixed in 1.12.10, 1.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16276/ (Markdown: https://insights.sbomify.com/CVE-2019-16276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16276
- OSV: https://osv.dev/vulnerability/CVE-2019-16276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16276/
Summaries are generated and may contain mistakes; the official description above is the record.
