CVE-2019-16303 JHipster Kotlin using insecure source of randomness `RandomStringUtils` before v1.2.0
Insecure randomness in generated password reset tokens allows attackers to predict other users' reset URLs, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-16303?
CVE-2019-16303 is a critical vulnerability in n/a, published on 13 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A class generated by the Generator in JHipster before 6.3.0 and JHipster Kotlin through 1.1.0 produces code that uses an insecure source of randomness (apache.commons.lang3 RandomStringUtils). This allows an attacker (if able to obtain their own password reset URL) to compute the value for all other password resets for other accounts, thus allowing privilege escalation or account takeover.
Weakness: CWE-338
Which versions are affected by CVE-2019-16303?
4 open source packages ship an affected version, including generator-jhipster and generator-jhipster-kotlin. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
generator-jhipster npm | All versions | 6.3.0 |
generator-jhipster npm | All versions | 6.3.0 |
generator-jhipster-kotlin npm | All versions | 1.2.0 |
generator-jhipster-kotlin npm | All versions | 1.2.0 |
Products include Jhipster Jhipster, Jhipster Jhipster Kotlin.
How do I fix CVE-2019-16303?
Upgrade generator-jhipster to 6.3.0 or later.
Is CVE-2019-16303 being exploited?
There is no known exploitation of CVE-2019-16303 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-j3rh-8vwq-wh84, GHSA-mwp6-j9wf-968c.