# CVE-2019-16318: Pimcore Unrestricted Upload of File with Dangerous Type

> Attackers with limited privileges can bypass file extension restrictions by using long filenames, potentially uploading malicious PHP files for code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cxj7-4jpj-2q38, SNYK-PHP-PIMCOREPIMCORE-451598

## What is CVE-2019-16318?

CVE-2019-16318 is a high-severity vulnerability in Pimcore Pimcore, published on 14 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Pimcore before 5.7.1, an attacker with limited privileges can bypass file-extension restrictions via a 256-character filename, as demonstrated by the failure of automatic renaming of .php to .php.txt for long filenames, a different vulnerability than CVE-2019-10867 and CVE-2019-16317.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-16318?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 5.7.1 |
| `pimcore/pimcore` | Packagist | All versions | 5.7.1 |

Products: Pimcore Pimcore.

## How do I fix CVE-2019-16318?

Upgrade pimcore/pimcore to 5.7.1 or later.

## Is CVE-2019-16318 being exploited?

There is no known exploitation of CVE-2019-16318 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16318 and fix it if it is affected.

What it is: CVE-2019-16318 is a high-severity vulnerability in Pimcore Pimcore, published on 14 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16318 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 5.7.1
- pimcore/pimcore (Packagist): affected all versions; fixed in 5.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16318/ (Markdown: https://insights.sbomify.com/CVE-2019-16318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16318
- OSV: https://osv.dev/vulnerability/CVE-2019-16318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16318/
Summaries are generated and may contain mistakes; the official description above is the record.
