CVE-2019-16328 Duplicate Advisory: Possible remote code execution via a remote procedure call

High 7.5 Published Updated

Remote attackers can execute arbitrary code on RPyC services by manipulating object attributes to construct malicious remote procedure calls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-16328?

CVE-2019-16328 is a high-severity code injection vulnerability in n/a, published on 3 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In RPyC 4.1.x through 4.1.1, a remote attacker can dynamically modify object attributes to construct a remote procedure call that executes code for an RPyC service with default configuration settings.

Weakness: CWE-1321

Which versions are affected by CVE-2019-16328?

5 open source packages ship an affected version, including rpyc. It affects 1 product.

PackageAffectedFixed in
rpyc PyPIFrom 4.1.04.1.1
rpyc PyPIFrom 4.1.04.1.1
rpyc PyPIFrom 4.1.04.1.2
rpyc PyPIFrom 4.1.04.1.2
rpyc PyPIFrom 4.1.04.1.2
Linux distribution packages (5)
python-rpyc SUSE:Package Hub 15 SP1All versions4.1.5-bp151.2.3.1
python-rpyc-test SUSE:Package Hub 15 SP1All versions4.1.5-bp151.2.3.1
python-rpyc openSUSE:Leap 15.1All versions4.1.5-lp151.3.3.1
python-rpyc-test openSUSE:Leap 15.1All versions4.1.5-lp151.3.3.1
python-rpyc openSUSE:TumbleweedAll versions6.0.0-1.2

Products include Rpyc Project Rpyc.

How do I fix CVE-2019-16328?

Upgrade rpyc to a fixed version for your release line: 4.1.1 or 4.1.2.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2019-16328 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-16328 exists.

Public exploit code: 1 Metasploit module.

Sources

Also known as GHSA-9ggp-4jpr-7ppj, GHSA-pj4g-4488-wmxm, PYSEC-2019-118, openSUSE-SU-2020:0685-1, openSUSE-SU-2020:0763-1, openSUSE-SU-2024:11268-1 and 1 more.

Is CVE-2019-16328 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free