# CVE-2019-16328: Duplicate Advisory: Possible remote code execution via a remote procedure call

> Remote attackers can execute arbitrary code on RPyC services by manipulating object attributes to construct malicious remote procedure calls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9ggp-4jpr-7ppj, GHSA-pj4g-4488-wmxm, PYSEC-2019-118, openSUSE-SU-2020:0685-1, openSUSE-SU-2020:0763-1, openSUSE-SU-2024:11268-1, openSUSE-SU-2024:14162-1

## What is CVE-2019-16328?

CVE-2019-16328 is a high-severity code injection vulnerability in n/a, published on 3 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In RPyC 4.1.x through 4.1.1, a remote attacker can dynamically modify object attributes to construct a remote procedure call that executes code for an RPyC service with default configuration settings.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2019-16328?

5 open source packages ship an affected version, including rpyc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rpyc` | PyPI | From 4.1.0 | 4.1.1 |
| `rpyc` | PyPI | From 4.1.0 | 4.1.1 |
| `rpyc` | PyPI | From 4.1.0 | 4.1.2 |
| `rpyc` | PyPI | From 4.1.0 | 4.1.2 |
| `rpyc` | PyPI | From 4.1.0 | 4.1.2 |
| `python-rpyc` | SUSE:Package Hub 15 SP1 | All versions | 4.1.5-bp151.2.3.1 |
| `python-rpyc-test` | SUSE:Package Hub 15 SP1 | All versions | 4.1.5-bp151.2.3.1 |
| `python-rpyc` | openSUSE:Leap 15.1 | All versions | 4.1.5-lp151.3.3.1 |
| `python-rpyc-test` | openSUSE:Leap 15.1 | All versions | 4.1.5-lp151.3.3.1 |
| `python-rpyc` | openSUSE:Tumbleweed | All versions | 6.0.0-1.2 |

Products: Rpyc Project Rpyc.

## How do I fix CVE-2019-16328?

Upgrade rpyc to a fixed version for your release line: 4.1.1 or 4.1.2.

## Is CVE-2019-16328 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-16328 exists.

Public exploit code:

- RPyC 4.1.0 through 4.1.1 Remote Command Execution (metasploit)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16328 and fix it if it is affected.

What it is: CVE-2019-16328 is a high-severity code injection vulnerability in n/a, published on 3 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-16328 exists.

Affected packages and fixed versions:
- rpyc (PyPI): affected from 4.1.0; fixed in 4.1.1
- rpyc (PyPI): affected from 4.1.0; fixed in 4.1.1
- rpyc (PyPI): affected from 4.1.0; fixed in 4.1.2
- rpyc (PyPI): affected from 4.1.0; fixed in 4.1.2
- rpyc (PyPI): affected from 4.1.0; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16328/ (Markdown: https://insights.sbomify.com/CVE-2019-16328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16328
- OSV: https://osv.dev/vulnerability/CVE-2019-16328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16328/
Summaries are generated and may contain mistakes; the official description above is the record.
