CVE-2019-16335 Polymorphic Typing issue in FasterXML jackson-databind
Attackers can execute arbitrary code via polymorphic typing in jackson-databind when deserializing untrusted data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-16335?
CVE-2019-16335 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 15 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Polymorphic Typing issue was discovered in FasterXML jackson-databind before 2.9.10. It is related to com.zaxxer.hikari.HikariDataSource. This is a different vulnerability than CVE-2019-14540.
Weakness: CWE-502
Which versions are affected by CVE-2019-16335?
6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 17 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.8.11.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.8.11.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind, Fedoraproject Fedora, Netapp Oncommand Api Services, Netapp Oncommand Workflow Automation, Netapp Steelstore Cloud Integrated Storage and 11 more.
How do I fix CVE-2019-16335?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.8.11.5 or 2.9.10.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2019-16335 being exploited?
There is no known exploitation of CVE-2019-16335 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-RO69102, DEBIAN-CVE-2019-16335, GHSA-85cw-hj65-qqv9, ROOT-APP-MAVEN-CVE-2019-16335, UBUNTU-CVE-2019-16335.