{"answers":{"affected":"2 open source packages ship an affected version, including org.gradle:gradle-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16370 in the wild and no public exploit code.","fix":"Upgrade org.gradle:gradle-core to 6.0 or later.","what":"CVE-2019-16370 is a medium-severity vulnerability in n/a, published on 16 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16370 and fix it if it is affected.\n\nWhat it is: CVE-2019-16370 is a medium-severity vulnerability in n/a, published on 16 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16370 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.gradle:gradle-core (Maven): affected all versions; fixed in 6.0\n- org.gradle:gradle-core (Maven): affected all versions; fixed in 6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16370/ (Markdown: https://insights.sbomify.com/CVE-2019-16370/index.md)","id":"CVE-2019-16370","markdown":"https://insights.sbomify.com/CVE-2019-16370/index.md","name":"CVE-2019-16370","record":{"aliases":["DEBIAN-CVE-2019-16370","GHSA-hhr2-f668-ff2w","OESA-2021-1309","UBUNTU-CVE-2019-16370","openSUSE-SU-2024:10817-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Gradle PGP signing plugin","requires_auth":"none","summary":"Attackers can replace Gradle artifacts with malicious ones due to SHA-1 collision vulnerabilities in the PGP signing plugin.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gradle","vendor":"gradle"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.","ecosystems":["Maven","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use of a weak cryptographic algorithm in Gradle","id":"CVE-2019-16370","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2019"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2019-16371"},"packages":[{"ecosystem":"Maven","fixed":["6.0"],"introduced":["0"],"last_affected":[],"package":"org.gradle:gradle-core","purl":null,"source":"GHSA-hhr2-f668-ff2w"},{"ecosystem":"Maven","fixed":["6.0"],"introduced":["0"],"last_affected":[],"package":"org.gradle:gradle-core","purl":"pkg:maven/org.gradle/gradle-core","source":"GHSA-hhr2-f668-ff2w"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.4.1-7.2"],"introduced":["0"],"last_affected":[],"package":"gradle","purl":"pkg:rpm/opensuse/gradle\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10817-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2019-16366"},"products":["n/a"],"published":"2019-09-16","related":[{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2019-15052","kev_date_added":null,"published":"2019-08-14"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2016-6199","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":8.8,"headline":"Local privilege escalation through system temporary directory","id":"CVE-2021-29428","kev_date_added":null,"published":"2021-04-13"},{"cvss_score":8.6,"headline":"Gradle fails to disable repositories which can expose builds to malicious artifacts","id":"CVE-2026-22816","kev_date_added":null,"published":"2026-01-16"},{"cvss_score":8.6,"headline":"Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts","id":"CVE-2026-22865","kev_date_added":null,"published":"2026-01-16"},{"cvss_score":8.1,"headline":"Deserialization in n/a","id":"CVE-2021-41588","kev_date_added":null,"published":"2021-09-24"},{"cvss_score":8,"headline":"Repository content filters do not work in Settings pluginManagement","id":"CVE-2021-29427","kev_date_added":null,"published":"2021-04-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can replace Gradle artifacts with malicious ones due to SHA-1 collision vulnerabilities in the PGP signing plugin.","url":"https://insights.sbomify.com/CVE-2019-16370/"}