CVE-2019-16405 Improper Input Validation in Centreon Web
An administrator can achieve remote code execution by modifying Macro Expression location settings in Centreon Web.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-16405?
CVE-2019-16405 is a high-severity code injection vulnerability in Centreon Centreon Web, published on 21 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Centreon Web before 2.8.30, 18.10.x before 18.10.8, 19.04.x before 19.04.5 and 19.10.x before 19.10.2 allows Remote Code Execution by an administrator who can modify Macro Expression location settings. CVE-2019-16405 and CVE-2019-17501 are similar to one another and may be the same.
Which versions are affected by CVE-2019-16405?
4 open source packages ship an affected version, including centreon/centreon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
centreon/centreon Packagist | All versions | 18.10.8 |
centreon/centreon Packagist | All versions | 18.10.8 |
centreon/centreon Packagist | From 19.0.0 | 19.04.5 |
centreon/centreon Packagist | From 19.0.0 | 19.04.5 |
Products include Centreon Centreon Web.
How do I fix CVE-2019-16405?
Upgrade centreon/centreon to a fixed version for your release line: 18.10.8 or 19.04.5.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-16405 being exploited?
There is no known exploitation of CVE-2019-16405 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.
Other vulnerabilities in Centreon Centreon Web
Sources
Also known as GHSA-4f26-v6fr-9hmp.