# CVE-2019-16409: SilverStripe Versioned Files module Unpublished files are exposed publicly

> Attackers can access unpublished file versions in SilverStripe 3.x by guessing URLs, exposing sensitive data to unauthorized users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xm6j-x342-gwq9

## What is CVE-2019-16409?

CVE-2019-16409 is a medium-severity vulnerability in Silverstripe Silverstripe, published on 26 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the Versioned Files module through 2.0.3 for SilverStripe 3.x, unpublished versions of files are publicly exposed to anyone who can guess their URL. This guess could be highly informed by a basic understanding of the symbiote/silverstripe-versionedfiles source code. (Users who upgrade from SilverStripe 3.x to 4.x and had Versioned Files installed have no further need for this module, because the 4.x release has built-in versioning. However, nothing in the upgrade process automates the destruction of these insecure artefacts, nor alerts the user to the criticality of destruction.)

## Which versions are affected by CVE-2019-16409?

6 open source packages ship an affected version, including silverstripe/framework and symbiote/silverstripe-versionedfiles. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.3.5 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.3.5 |
| `silverstripe/framework` | Packagist | From 4.4.0 | 4.4.4 |
| `silverstripe/framework` | Packagist | From 4.4.0 | 4.4.4 |
| `symbiote/silverstripe-versionedfiles` | Packagist | All versions to 2.0.3 | None |
| `symbiote/silverstripe-versionedfiles` | Packagist | All versions to 2.0.3 | None |

Products: Silverstripe Silverstripe, Symbiote Versionedfiles.

## How do I fix CVE-2019-16409?

Upgrade silverstripe/framework to a fixed version for your release line: 4.3.5 or 4.4.4.

## Is CVE-2019-16409 being exploited?

There is no known exploitation of CVE-2019-16409 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16409 and fix it if it is affected.

What it is: CVE-2019-16409 is a medium-severity vulnerability in Silverstripe Silverstripe, published on 26 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16409 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.3.5
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.3.5
- silverstripe/framework (Packagist): affected from 4.4.0; fixed in 4.4.4
- silverstripe/framework (Packagist): affected from 4.4.0; fixed in 4.4.4
- symbiote/silverstripe-versionedfiles (Packagist): affected all versions up to 2.0.3; no fix listed
- symbiote/silverstripe-versionedfiles (Packagist): affected all versions up to 2.0.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16409/ (Markdown: https://insights.sbomify.com/CVE-2019-16409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16409
- OSV: https://osv.dev/vulnerability/CVE-2019-16409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16409/
Summaries are generated and may contain mistakes; the official description above is the record.
