# CVE-2019-16530: Unrestricted Upload of File with Dangerous Type in Sonatype Nexus Repository Manager

> Attackers can achieve remote code execution in Sonatype Nexus Repository Manager and IQ Server via improper file upload handling.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hmjv-px3j-933c

## What is CVE-2019-16530?

CVE-2019-16530 is a high-severity vulnerability in Sonatype Nexus Repository Manager, published on 21 Oct 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Sonatype Nexus Repository Manager 2.x before 2.14.15 and 3.x before 3.19, and IQ Server before 72, has remote code execution.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-16530?

4 open source packages ship an affected version, including org.sonatype.nexus:nexus-repository. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.sonatype.nexus:nexus-repository` | Maven | From 2.0.0 | 2.14.15 |
| `org.sonatype.nexus:nexus-repository` | Maven | From 2.0.0 | 2.14.15 |
| `org.sonatype.nexus:nexus-repository` | Maven | From 3.0.0 | 3.19.0 |
| `org.sonatype.nexus:nexus-repository` | Maven | From 3.0.0 | 3.19.0 |

Products: Sonatype Nexus Iq Server, Sonatype Nexus Repository Manager.

## How do I fix CVE-2019-16530?

Upgrade org.sonatype.nexus:nexus-repository to a fixed version for your release line: 2.14.15 or 3.19.0.

## Is CVE-2019-16530 being exploited?

There is no known exploitation of CVE-2019-16530 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16530 and fix it if it is affected.

What it is: CVE-2019-16530 is a high-severity vulnerability in Sonatype Nexus Repository Manager, published on 21 Oct 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16530 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.sonatype.nexus:nexus-repository (Maven): affected from 2.0.0; fixed in 2.14.15
- org.sonatype.nexus:nexus-repository (Maven): affected from 2.0.0; fixed in 2.14.15
- org.sonatype.nexus:nexus-repository (Maven): affected from 3.0.0; fixed in 3.19.0
- org.sonatype.nexus:nexus-repository (Maven): affected from 3.0.0; fixed in 3.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16530/ (Markdown: https://insights.sbomify.com/CVE-2019-16530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16530
- OSV: https://osv.dev/vulnerability/CVE-2019-16530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16530/
Summaries are generated and may contain mistakes; the official description above is the record.
