{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16538 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:script-security to 1.68 or later.","what":"CVE-2019-16538 is a high-severity code injection vulnerability in Jenkins Script Security Plugin, published on 21 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16538 and fix it if it is affected.\n\nWhat it is: CVE-2019-16538 is a high-severity code injection vulnerability in Jenkins Script Security Plugin, published on 21 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16538 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.68\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.68\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16538/ (Markdown: https://insights.sbomify.com/CVE-2019-16538/index.md)","id":"CVE-2019-16538","markdown":"https://insights.sbomify.com/CVE-2019-16538/index.md","name":"CVE-2019-16538","record":{"aliases":["GHSA-62pm-mgrh-7p69"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Script Security Plugin","requires_auth":"low_privilege","summary":"Attackers can bypass the sandbox to execute arbitrary code in Jenkins scripts via default parameter expressions in closures.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"script_security","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.67 and earlier related to the handling of default parameter expressions in closures allowed attackers to execute arbitrary code in sandboxed scripts.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Authorization in Jenkins Script Security Plugin","id":"CVE-2019-16538","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Missing permission check in Jenkins Support Core Plugin","id":"CVE-2019-16539"},"packages":[{"ecosystem":"Maven","fixed":["1.68"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":null,"source":"GHSA-62pm-mgrh-7p69"},{"ecosystem":"Maven","fixed":["1.68"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":"pkg:maven/org.jenkins-ci.plugins/script-security","source":"GHSA-62pm-mgrh-7p69"}],"prev":{"headline":"Stack overflow leading to DoS can be triggered by a malicious authenticated client.","id":"CVE-2019-16536"},"products":["Jenkins Script Security Plugin"],"published":"2019-11-21","related":[{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin Sandbox Bypass","id":"CVE-2019-1003029","kev_date_added":"2022-04-25","published":"2019-03-08"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43401","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin sandbox bypass vulnerability","id":"CVE-2022-43403","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43404","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerability in Jenkins Script Security Plugin","id":"CVE-2020-2279","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":9.9,"headline":"Improper Control of Generation of Code in Jenkins Script Security Plugin","id":"CVE-2019-10431","kev_date_added":null,"published":"2019-10-01"},{"cvss_score":9.8,"headline":"Jenkins Script Security Plugin has sandbox bypass vulnerability involving crafted constructor bodies","id":"CVE-2024-34144","kev_date_added":null,"published":"2024-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Attackers can bypass the sandbox to execute arbitrary code in Jenkins scripts via default parameter expressions in closures.","url":"https://insights.sbomify.com/CVE-2019-16538/"}