# CVE-2019-16543: Plaintext Storage in Jenkins Spira Importer Plugin

> Attackers with master file system access can read unencrypted credentials stored by the Jenkins Spira Importer Plugin.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pwg7-4hxv-v4cw

## What is CVE-2019-16543?

CVE-2019-16543 is a medium-severity vulnerability in Jenkins Spira Importer Plugin, published on 21 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins Spira Importer Plugin 3.2.2 and earlier stores credentials unencrypted in its global configuration file on the Jenkins master where they can be viewed by users with access to the master file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-16543?

2 open source packages ship an affected version, including com.inflectra.spiratest.plugins:inflectra-spira-integration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.inflectra.spiratest.plugins:inflectra-spira-integration` | Maven | All versions | 3.2.3 |
| `com.inflectra.spiratest.plugins:inflectra-spira-integration` | Maven | All versions | 3.2.3 |

Products: Jenkins Spira Importer.

## How do I fix CVE-2019-16543?

Upgrade com.inflectra.spiratest.plugins:inflectra-spira-integration to 3.2.3 or later.

## Is CVE-2019-16543 being exploited?

There is no known exploitation of CVE-2019-16543 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Spira Importer Plugin

- [CVE-2019-16558](https://insights.sbomify.com/CVE-2019-16558/): Improper Certificate Validation in Jenkins Spira Importer Plugin (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16543 and fix it if it is affected.

What it is: CVE-2019-16543 is a medium-severity vulnerability in Jenkins Spira Importer Plugin, published on 21 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16543 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.inflectra.spiratest.plugins:inflectra-spira-integration (Maven): affected all versions; fixed in 3.2.3
- com.inflectra.spiratest.plugins:inflectra-spira-integration (Maven): affected all versions; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16543/ (Markdown: https://insights.sbomify.com/CVE-2019-16543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16543
- OSV: https://osv.dev/vulnerability/CVE-2019-16543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16543/
Summaries are generated and may contain mistakes; the official description above is the record.
