{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins.m2release:m2release. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16549 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins.m2release:m2release to 0.16.2 or later.","what":"CVE-2019-16549 is a high-severity vulnerability in Jenkins Maven Release Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16549 and fix it if it is affected.\n\nWhat it is: CVE-2019-16549 is a high-severity vulnerability in Jenkins Maven Release Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16549 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins.m2release:m2release (Maven): affected all versions; fixed in 0.16.2\n- org.jenkins-ci.plugins.m2release:m2release (Maven): affected all versions; fixed in 0.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16549/ (Markdown: https://insights.sbomify.com/CVE-2019-16549/index.md)","id":"CVE-2019-16549","markdown":"https://insights.sbomify.com/CVE-2019-16549/index.md","name":"CVE-2019-16549","record":{"aliases":["GHSA-7mf5-79gv-66gh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Maven plugin","requires_auth":"none","summary":"Man-in-the-middle attackers can exploit XML external entity vulnerabilities in the Jenkins Maven Release Plugin to read sensitive data or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"maven","vendor":"jenkins"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins Maven Release Plugin 0.16.1 and earlier does not configure the XML parser to prevent XML external entity (XXE) attacks, allowing man-in-the-middle attackers to have Jenkins parse crafted XML documents.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Maven Release Plug-in Plugin XXE vulnerability","id":"CVE-2019-16549","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site request forgery (CSRF) vulnerability in Jenkins Maven Release Plugin","id":"CVE-2019-16550"},"packages":[{"ecosystem":"Maven","fixed":["0.16.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins.m2release:m2release","purl":null,"source":"GHSA-7mf5-79gv-66gh"},{"ecosystem":"Maven","fixed":["0.16.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins.m2release:m2release","purl":"pkg:maven/org.jenkins-ci.plugins.m2release/m2release","source":"GHSA-7mf5-79gv-66gh"}],"prev":{"headline":"Jenkins Google Compute Engine Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2019-16548"},"products":["Jenkins Maven Release Plugin"],"published":"2019-12-17","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery (CSRF) vulnerability in Jenkins Maven Release Plugin","id":"CVE-2019-16550","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":6.5,"headline":"Maven Integration Plugin did not mask sensitive values in module build logs","id":"CVE-2019-10358","kev_date_added":null,"published":"2019-07-31"},{"cvss_score":5.9,"headline":"MitM on Jenkins Maven Plugin","id":"CVE-2017-1000397","kev_date_added":null,"published":"2018-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Man-in-the-middle attackers can exploit XML external entity vulnerabilities in the Jenkins Maven Release Plugin to read sensitive data or cause denial of service.","url":"https://insights.sbomify.com/CVE-2019-16549/"}