{"answers":{"affected":"2 open source packages ship an affected version, including com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16551 in the wild and no public exploit code.","fix":"Upgrade com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.30.2 or later.","what":"CVE-2019-16551 is a high-severity vulnerability in Jenkins Gerrit Trigger Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16551 and fix it if it is affected.\n\nWhat it is: CVE-2019-16551 is a high-severity vulnerability in Jenkins Gerrit Trigger Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16551 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.30.2\n- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.30.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16551/ (Markdown: https://insights.sbomify.com/CVE-2019-16551/index.md)","id":"CVE-2019-16551","markdown":"https://insights.sbomify.com/CVE-2019-16551/index.md","name":"CVE-2019-16551","record":{"aliases":["GHSA-vmvp-2hhx-rgm8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Gerrit Plugin","requires_auth":"none","summary":"Attackers can force Jenkins to connect to malicious servers using attacker-controlled credentials via CSRF in the Gerrit Trigger Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"gerrit_trigger","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery vulnerability in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery in Jenkins Gerrit Trigger Plugin","id":"CVE-2019-16551","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Missing permission check in Jenkins Gerrit Trigger Plugin","id":"CVE-2019-16552"},"packages":[{"ecosystem":"Maven","fixed":["2.30.2"],"introduced":["0"],"last_affected":[],"package":"com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger","purl":null,"source":"GHSA-vmvp-2hhx-rgm8"},{"ecosystem":"Maven","fixed":["2.30.2"],"introduced":["0"],"last_affected":[],"package":"com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger","purl":"pkg:maven/com.sonyericsson.hudson.plugins.gerrit/gerrit-trigger","source":"GHSA-vmvp-2hhx-rgm8"}],"prev":{"headline":"Cross-site request forgery (CSRF) vulnerability in Jenkins Maven Release Plugin","id":"CVE-2019-16550"},"products":["Jenkins Gerrit Trigger Plugin"],"published":"2019-12-17","related":[{"cvss_score":6.5,"headline":"Cross-site request forgery in Jenkins Gerrit Trigger Plugin","id":"CVE-2023-24423","kev_date_added":null,"published":"2023-01-24"},{"cvss_score":5.4,"headline":"Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin","id":"CVE-2022-29039","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":5.4,"headline":"Missing permission check in Jenkins Gerrit Trigger Plugin","id":"CVE-2019-16552","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":5.4,"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000106","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":4.3,"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000105","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Attackers can force Jenkins to connect to malicious servers using attacker-controlled credentials via CSRF in the Gerrit Trigger Plugin.","url":"https://insights.sbomify.com/CVE-2019-16551/"}