# CVE-2019-16551: Cross-Site Request Forgery in Jenkins Gerrit Trigger Plugin

> Attackers can force Jenkins to connect to malicious servers using attacker-controlled credentials via CSRF in the Gerrit Trigger Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vmvp-2hhx-rgm8

## What is CVE-2019-16551?

CVE-2019-16551 is a high-severity vulnerability in Jenkins Gerrit Trigger Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-16551?

2 open source packages ship an affected version, including com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger` | Maven | All versions | 2.30.2 |
| `com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger` | Maven | All versions | 2.30.2 |

Products: Jenkins Gerrit Trigger.

## How do I fix CVE-2019-16551?

Upgrade com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.30.2 or later.

## Is CVE-2019-16551 being exploited?

There is no known exploitation of CVE-2019-16551 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Gerrit Trigger Plugin

- [CVE-2023-24423](https://insights.sbomify.com/CVE-2023-24423/): Cross-site request forgery in Jenkins Gerrit Trigger Plugin (medium 6.5)
- [CVE-2022-29039](https://insights.sbomify.com/CVE-2022-29039/): Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin (medium 5.4)
- [CVE-2019-16552](https://insights.sbomify.com/CVE-2019-16552/): Missing permission check in Jenkins Gerrit Trigger Plugin (medium 5.4)
- [CVE-2018-1000106](https://insights.sbomify.com/CVE-2018-1000106/): Incorrect Authorization in Jenkins Gerrit Trigger Plugin (medium 5.4)
- [CVE-2018-1000105](https://insights.sbomify.com/CVE-2018-1000105/): Incorrect Authorization in Jenkins Gerrit Trigger Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16551 and fix it if it is affected.

What it is: CVE-2019-16551 is a high-severity vulnerability in Jenkins Gerrit Trigger Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16551 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.30.2
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.30.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16551/ (Markdown: https://insights.sbomify.com/CVE-2019-16551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16551
- OSV: https://osv.dev/vulnerability/CVE-2019-16551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16551/
Summaries are generated and may contain mistakes; the official description above is the record.
