# CVE-2019-16558: Improper Certificate Validation in Jenkins Spira Importer Plugin

> The Jenkins Spira Importer Plugin disables SSL/TLS certificate validation, allowing attackers to intercept or manipulate encrypted communications.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2j5w-cwc3-8hxw

## What is CVE-2019-16558?

CVE-2019-16558 is a high-severity vulnerability in Jenkins Spira Importer Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Spira Importer Plugin 3.2.3 and earlier disables SSL/TLS certificate validation for the Jenkins master JVM.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-16558?

2 open source packages ship an affected version, including com.inflectra.spiratest.plugins:inflectra-spira-integration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.inflectra.spiratest.plugins:inflectra-spira-integration` | Maven | All versions | 3.2.4 |
| `com.inflectra.spiratest.plugins:inflectra-spira-integration` | Maven | All versions | 3.2.4 |

Products: Jenkins Spira Importer.

## How do I fix CVE-2019-16558?

Upgrade com.inflectra.spiratest.plugins:inflectra-spira-integration to 3.2.4 or later.

## Is CVE-2019-16558 being exploited?

There is no known exploitation of CVE-2019-16558 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Spira Importer Plugin

- [CVE-2019-16543](https://insights.sbomify.com/CVE-2019-16543/): Plaintext Storage in Jenkins Spira Importer Plugin (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16558 and fix it if it is affected.

What it is: CVE-2019-16558 is a high-severity vulnerability in Jenkins Spira Importer Plugin, published on 17 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16558 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.inflectra.spiratest.plugins:inflectra-spira-integration (Maven): affected all versions; fixed in 3.2.4
- com.inflectra.spiratest.plugins:inflectra-spira-integration (Maven): affected all versions; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16558/ (Markdown: https://insights.sbomify.com/CVE-2019-16558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16558
- OSV: https://osv.dev/vulnerability/CVE-2019-16558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16558/
Summaries are generated and may contain mistakes; the official description above is the record.
