{"answers":{"affected":"2 open source packages ship an affected version, including com.paul8620.jenkins.plugins:pipeline-aggregator-view. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16564 in the wild and no public exploit code.","fix":"Upgrade com.paul8620.jenkins.plugins:pipeline-aggregator-view to 1.9 or later.","what":"CVE-2019-16564 is a medium-severity cross-site scripting vulnerability in Jenkins Pipeline Aggregator View Plugin, published on 17 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16564 and fix it if it is affected.\n\nWhat it is: CVE-2019-16564 is a medium-severity cross-site scripting vulnerability in Jenkins Pipeline Aggregator View Plugin, published on 17 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16564 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.paul8620.jenkins.plugins:pipeline-aggregator-view (Maven): affected all versions; fixed in 1.9\n- com.paul8620.jenkins.plugins:pipeline-aggregator-view (Maven): affected all versions; fixed in 1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16564/ (Markdown: https://insights.sbomify.com/CVE-2019-16564/index.md)","id":"CVE-2019-16564","markdown":"https://insights.sbomify.com/CVE-2019-16564/index.md","name":"CVE-2019-16564","record":{"aliases":["GHSA-jf8x-943c-r4h6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Pipeline Aggregator View Plugin allows attackers to execute scripts via job names or stage names, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"pipeline_aggregator_view","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Pipeline Aggregator View Plugin 1.8 and earlier does not escape information shown on its view, resulting in a stored XSS vulnerability exploitable by attackers able to affects view content such as job display name or pipeline stage names.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Pipeline Aggregator View Plugin stored XSS vulnerability","id":"CVE-2019-16564","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Team Concert Plugin cross-site request forgery vulnerability","id":"CVE-2019-16565"},"packages":[{"ecosystem":"Maven","fixed":["1.9"],"introduced":["0"],"last_affected":[],"package":"com.paul8620.jenkins.plugins:pipeline-aggregator-view","purl":null,"source":"GHSA-jf8x-943c-r4h6"},{"ecosystem":"Maven","fixed":["1.9"],"introduced":["0"],"last_affected":[],"package":"com.paul8620.jenkins.plugins:pipeline-aggregator-view","purl":"pkg:maven/com.paul8620.jenkins.plugins/pipeline-aggregator-view","source":"GHSA-jf8x-943c-r4h6"}],"prev":{"headline":"Cross site scripting in Jenkins Mission Control Plugin","id":"CVE-2019-16563"},"products":["Jenkins Pipeline Aggregator View Plugin"],"published":"2019-12-17","related":[{"cvss_score":5.4,"headline":"Jenkins Pipeline Aggregator View Plugin vulnerable to Cross-site Scripting","id":"CVE-2023-28670","kev_date_added":null,"published":"2023-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Pipeline Aggregator View Plugin allows attackers to execute scripts via job names or stage names, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2019-16564/"}