# CVE-2019-16699: sr_freecap for Typo3 RCE Vulnerability

> Attackers can execute arbitrary Extbase actions leading to remote code execution via unsanitized input in the freeCap CAPTCHA extension for TYPO3.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-598p-rv6p-g7qc

## What is CVE-2019-16699?

CVE-2019-16699 is a critical code injection vulnerability in n/a, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The sr_freecap (aka freeCap CAPTCHA) extension 2.4.5 and below and 2.5.2 and below for TYPO3 fails to sanitize user input, which allows execution of arbitrary Extbase actions, resulting in Remote Code Execution.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-16699?

4 open source packages ship an affected version, including sjbr/sr-freecap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sjbr/sr-freecap` | Packagist | All versions | 2.4.6 |
| `sjbr/sr-freecap` | Packagist | All versions | 2.4.6 |
| `sjbr/sr-freecap` | Packagist | From 2.5.0 | 2.5.3 |
| `sjbr/sr-freecap` | Packagist | From 2.5.0 | 2.5.3 |

Products: Sr Freecap Project Sr Freecap.

## How do I fix CVE-2019-16699?

Upgrade sjbr/sr-freecap to a fixed version for your release line: 2.4.6 or 2.5.3.

## Is CVE-2019-16699 being exploited?

There is no known exploitation of CVE-2019-16699 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16699 and fix it if it is affected.

What it is: CVE-2019-16699 is a critical code injection vulnerability in n/a, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16699 in the wild and no public exploit code.

Affected packages and fixed versions:
- sjbr/sr-freecap (Packagist): affected all versions; fixed in 2.4.6
- sjbr/sr-freecap (Packagist): affected all versions; fixed in 2.4.6
- sjbr/sr-freecap (Packagist): affected from 2.5.0; fixed in 2.5.3
- sjbr/sr-freecap (Packagist): affected from 2.5.0; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16699/ (Markdown: https://insights.sbomify.com/CVE-2019-16699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16699
- OSV: https://osv.dev/vulnerability/CVE-2019-16699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16699/
Summaries are generated and may contain mistakes; the official description above is the record.
