# CVE-2019-16751: Devise Token Auth vulnerable to Cross-site Scripting

> Unauthenticated attackers can execute malicious JavaScript in victims' browsers via a crafted URL in the Devise Token Auth library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mvqr-r76c-wm5f

## What is CVE-2019-16751?

CVE-2019-16751 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Devise Token Auth through 1.1.2. The omniauth failure endpoint is vulnerable to Reflected Cross Site Scripting (XSS) through the message parameter. Unauthenticated attackers can craft a URL that executes a malicious JavaScript payload in the victim's browser. This affects the fallback_render method in the omniauth callbacks controller.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-16751?

2 open source packages ship an affected version, including devise_token_auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devise_token_auth` | RubyGems | From 0.1.33 | 1.1.3 |
| `devise_token_auth` | RubyGems | From 0.1.33 | 1.1.3 |

Products: Devise Token Auth Project Devise Token Auth.

## How do I fix CVE-2019-16751?

Upgrade devise_token_auth to 1.1.3 or later.

## Is CVE-2019-16751 being exploited?

There is no known exploitation of CVE-2019-16751 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16751 and fix it if it is affected.

What it is: CVE-2019-16751 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16751 in the wild and no public exploit code.

Affected packages and fixed versions:
- devise_token_auth (RubyGems): affected from 0.1.33; fixed in 1.1.3
- devise_token_auth (RubyGems): affected from 0.1.33; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16751/ (Markdown: https://insights.sbomify.com/CVE-2019-16751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16751
- OSV: https://osv.dev/vulnerability/CVE-2019-16751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16751/
Summaries are generated and may contain mistakes; the official description above is the record.
