CVE-2019-16760 Cargo prior to Rust 1.26.0 may download the wrong dependency
Attackers can hijack dependencies by squatting on crates.io when Cargo ignores package renaming keys, leading to malicious code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-16760?
CVE-2019-16760 is a medium-severity vulnerability in rust cargo, published on 30 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cargo prior to Rust 1.26.0 may download the wrong dependency if your package.toml file uses the `package` configuration key. Usage of the `package` key to rename dependencies in `Cargo.toml` is ignored in Rust 1.25.0 and prior. When Rust 1.25.0 and prior is used Cargo may download the wrong dependency, which could be squatted on crates.io to be a malicious package. This not only affects manifests that you write locally yourself, but also manifests published to crates.io. Rust 1.0.0 through Rust 1.25.0 is affected by this advisory because Cargo will ignore the `package` key in manifests. Rust 1.26.0 through Rust 1.30.0 are not affected and typically will emit an error because the `package` key is unstable. Rust 1.31.0 and after are not affected because Cargo understands the `package` key. Users of the affected versions are strongly encouraged to update their compiler to the latest available one. Preventing this issue from happening requires updating your compiler to be either Rust 1.26.0 or newer. There will be no point release for Rust versions prior to 1.26.0. Users of Rust 1.19.0 to Rust 1.25.0 can instead apply linked patches to mitigate the issue.
Which versions are affected by CVE-2019-16760?
2 open source packages ship an affected version, including cargo. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cargo crates.io | All versions | 0.27.0 |
cargo crates.io | All versions | 0.27.0 |
Products include Rust-Lang Rust.
How do I fix CVE-2019-16760?
Upgrade cargo to 0.27.0 or later.
Is CVE-2019-16760 being exploited?
There is no known exploitation of CVE-2019-16760 in the wild and no public exploit code.
Other vulnerabilities in rust cargo
Sources
Also known as ALPINE-CVE-2019-16760, CLEANSTART-2026-KD42401, DEBIAN-CVE-2019-16760, GHSA-9f3p-wvj7-q82x, GHSA-phjm-8x66-qw4r.