# CVE-2019-16761: Validator parsing discrepancy due to string encoding in NPM slp-validate 1.0.0

> An attacker can craft Bitcoin scripts to cause validation discrepancies, potentially leading to a hard fork in SLP consensus.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wmx6-vxcf-c3gr

## What is CVE-2019-16761?

CVE-2019-16761 is a medium-severity vulnerability in simpleledger slp-validate, published on 15 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slp-validate@1.0.0 npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-16761?

2 open source packages ship an affected version, including slp-validate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `slp-validate` | npm | From 1.0.0 | 1.0.1 |
| `slp-validate` | npm | From 1.0.0 | 1.0.1 |

Products: Simpleledger Slp-Validate.

## How do I fix CVE-2019-16761?

Upgrade slp-validate to 1.0.1 or later.

## Is CVE-2019-16761 being exploited?

There is no known exploitation of CVE-2019-16761 in the wild and no public exploit code.

## Other vulnerabilities in simpleledger slp-validate

- [CVE-2020-11072](https://insights.sbomify.com/CVE-2020-11072/): False-negative validation results in MINT transactions with invalid baton (high 8.6)
- [CVE-2020-15131](https://insights.sbomify.com/CVE-2020-15131/): False-positive validity for NFT1 genesis transactions in SLP Validate (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16761 and fix it if it is affected.

What it is: CVE-2019-16761 is a medium-severity vulnerability in simpleledger slp-validate, published on 15 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16761 in the wild and no public exploit code.

Affected packages and fixed versions:
- slp-validate (npm): affected from 1.0.0; fixed in 1.0.1
- slp-validate (npm): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16761/ (Markdown: https://insights.sbomify.com/CVE-2019-16761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16761
- OSV: https://osv.dev/vulnerability/CVE-2019-16761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16761/
Summaries are generated and may contain mistakes; the official description above is the record.
