{"answers":{"affected":"2 open source packages ship an affected version, including slpjs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16762 in the wild and no public exploit code.","fix":"Upgrade slpjs to 0.21.4 or later.","what":"CVE-2019-16762 is a medium-severity vulnerability in simpleledger slpjs, published on 15 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16762 and fix it if it is affected.\n\nWhat it is: CVE-2019-16762 is a medium-severity vulnerability in simpleledger slpjs, published on 15 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16762 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- slpjs (npm): affected all versions; fixed in 0.21.4\n- slpjs (npm): affected all versions; fixed in 0.21.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16762/ (Markdown: https://insights.sbomify.com/CVE-2019-16762/index.md)","id":"CVE-2019-16762","markdown":"https://insights.sbomify.com/CVE-2019-16762/index.md","name":"CVE-2019-16762","record":{"aliases":["GHSA-425c-ccf3-3jrr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"SLP JavaScript library","requires_auth":"high_privilege","summary":"Attackers can cause a hard-fork in SLP consensus by exploiting a parsing discrepancy in the slpjs library, affecting cryptocurrency applications.","user_interaction":"required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"slpjs","vendor":"simpleledger"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version \u003e= 0.21.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Validator parsing discrepancy due to string encoding in NPM slpjs","id":"CVE-2019-16762","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"business_logic","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"XSS in Pannellum from 2.5.0 through 2.5.4","id":"CVE-2019-16763"},"packages":[{"ecosystem":"npm","fixed":["0.21.4"],"introduced":["0"],"last_affected":[],"package":"slpjs","purl":null,"source":"GHSA-425c-ccf3-3jrr"},{"ecosystem":"npm","fixed":["0.21.4"],"introduced":["0"],"last_affected":[],"package":"slpjs","purl":"pkg:npm/slpjs","source":"GHSA-425c-ccf3-3jrr"}],"prev":{"headline":"Validator parsing discrepancy due to string encoding in NPM slp-validate 1.0.0","id":"CVE-2019-16761"},"products":["slpjs"],"published":"2019-11-15","related":[{"cvss_score":8.6,"headline":"False-negative validation results in MINT transactions with invalid baton","id":"CVE-2020-11071","kev_date_added":null,"published":"2020-05-12"},{"cvss_score":7.5,"headline":"False-positive validity for NFT1 genesis transactions in SLPJS","id":"CVE-2020-15130","kev_date_added":null,"published":"2020-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["simpleledger"]},"summary":"Attackers can cause a hard-fork in SLP consensus by exploiting a parsing discrepancy in the slpjs library, affecting cryptocurrency applications.","url":"https://insights.sbomify.com/CVE-2019-16762/"}