CVE-2019-16763 XSS in Pannellum from 2.5.0 through 2.5.4
Attackers can execute XSS via unsanitized URLs in Pannellum, potentially accessing user data or hijacking accounts if users click malicious hotspots.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-16763?
CVE-2019-16763 is a medium-severity cross-site scripting vulnerability in mpretroff pannellum, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an <iframe> could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted site did not have adequate CSRF protections) if the user clicked on a hot spot in the attacker's embedded panorama viewer. This was patched in version 2.5.5.
Weakness: CWE-79
Which versions are affected by CVE-2019-16763?
2 open source packages ship an affected version, including pannellum. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pannellum npm | From 2.5.0 | 2.5.5 |
pannellum npm | From 2.5.0 | 2.5.5 |
Products include Pannellum Pannellum.
How do I fix CVE-2019-16763?
Upgrade pannellum to 2.5.5 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-16763 being exploited?
There is no known exploitation of CVE-2019-16763 in the wild and no public exploit code.
Other vulnerabilities in mpretroff pannellum
Sources
Also known as GHSA-m52x-29pq-w3vv.